0

Today I needed to install a new version of sage, to overcome a problem with the Latex functionality in sage. The Linux Mint distribution contains a version of sage, but that one is even older than the one I had, so I had to install sage manually. This is very easy but it turns out that it requires GLIBC 2.27.

My Mint installation is fully up to date, but it only has GLIBC 2.23. And although I understand that a (probably rarely used) tool like sage is lagging behind, GLIBC seems rather fundamental.

Why does the Mint distribution not contain a more up-to-date version? Can I expect that I will receive version 2.27 any time soon from the standard update service?

  • 2
    Welcome , you should upgrade to linux-mint Tara (19). – GAD3R Jan 5 at 18:09
  • 1
    The differences between Mint and Ubuntu are all in desktop configuration, icons, fonts, and default pacakges installed. Upgrade to Mint 19 (based on Ubuntu 18.04) or see if there is a backports from a newer version of Ubuntu. – ivanivan Jan 5 at 20:41
  • Thanks for the replies. Unfortunately I am on a KDE version. It does not allow me to upgrade to Tara. – Leen Droogendijk Jan 6 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.