1

I am trying to boot my system but it goes to initramfs and nothing happens.

On using exit command it shows:

ALERT! UUID=3668c6fc-7986-490b-8642-705c4532d16a does not exist. Dropping to a shell!

On running these commands from live CD, I got this output :

mint@mint:~$ cat /etc/fstab
overlay / overlay rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0

mint@mint:~$ lsblk -f

NAME   FSTYPE   LABEL      UUID                                 MOUNTPOINT
loop0  squashfs                                                 /rofs
sda                                                             
├─sda1                                                          
└─sda2                                                          
sdb                                                             
└─sdb1 vfat     LINUX MINT A011-B668                            /cdrom

mint@mint:~$ sudo smartctl -a /dev/sda
=== START OF INFORMATION SECTION ===
Vendor:               
Product:              pc�F���pc�F���
Compliance:           SPC-4
User Capacity:        494,245,309,994,242,535 bytes [494 PB]
Logical block size:   1201668095 bytes
scsiModePageOffset: raw_curr too small, offset=190 resp_len=121 bd_len=186
scsiModePageOffset: raw_curr too small, offset=190 resp_len=121 bd_len=186
>> Terminate command early due to bad response to IEC mode page
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.
  • 1
    Could you edit your question including the outputs of cat /etc/fstab and lsblk -f? – steeling Jan 5 '19 at 14:04
1

In the comments, @steeling probably meant the /etc/fstab of the installed system, which might have been available in the initramfs. When running cat /etc/fstab from a live CD you got the /etc/fstab of the live CD environment, which is not very useful here.

But the lsblk -f output indicates that although the sda disk is detected and seems to have two partitions on it, there are no filesystem types, labels nor UUIDs listed for them. That makes me worry about accidental overwriting or possible hardware issues. It seems that the root filesystem of your Linux installation is no longer readable for some reason.

First, please run sudo smartctl -a /dev/sda and edit the output into your question. Feel free to hide the serial number and WWN in the beginning of the output, but it would be important to see the disk model and firmware version (to exclude the possibility of known firmware bugs) and the SMART health status and attribute values.

The next useful command would probably be sudo fdisk -l /dev/sda: its output should reveal the type of partitioning used and the types of the partitions... or if the disk has failed, the command might hang or report an error. Based on that information, it would be possible to plan the next actions to determine what has happened and whether or not it would be feasible to recover data from this disk.

If the sudo fdisk -l /dev/sda command hangs or produces an error message, you might also want to run sudo dmesg and see if the end of the output includes anything that looks like an error message.

You should also describe the system a bit more. Is this the first boot-up of a new system just after the installation of a Linux operating system, or has this system been working correctly before this issue started? If the system was working correctly before, do you know what was the last thing done with the system when it still worked?

It might be that the disk has some sort of problem that allows the system to read the partition table, the bootloader, kernel and initramfs from the beginning of the disk, but trying to read deeper into the disk causes it to fail.

If the system contained any files that have significant value and there are no backups available, STOP here and contact data recovery professionals. If the disk has a mechanical failure, further attempts to access it might cause more damage.

  • When I ran the /etc/fstab , it returns nothing and the lsblk -f returns command not found. It was not the first boot and I was just watching the videos using vlc and after that I just shut down the system and next day this happened. – abdemirza Jan 5 '19 at 16:02
  • OK, so the initramfs did not contain any meaningful /etc/fstab file and no lsblk tool - that is certainly possible. Please run the commands I suggested above using the Live CD. – telcoM Jan 5 '19 at 16:07
  • sudo fdisk -l /dev/sda returns cannot open /dev/sda : Input/output error – abdemirza Jan 5 '19 at 16:18
  • sudo dmesg returns a very long output with many errors like "softreset failed " , "I/O error , dev sda , logical block 244190624 , async page" – abdemirza Jan 5 '19 at 16:21
  • Is there anyway I can just load my disk and copy the useful data – abdemirza Jan 5 '19 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.