0

It seems that when I want to run qemu-system-x86_64 on a node via ssh -Y, I have to connect to the guest via VNC. So, here is an example:

[mahmood@rocks7 ~] ssh -Y compute-0-0
[mahmood@compute-0-0 ~] qemu-system-x86_64 -m 4096 -hda win7_x64_snap.img -boot c -usbdevice tablet -enable-kvm -device e1000,netdev=host_files -netdev user,net=10.0.2.0/24,id=host_files,restrict=off
qemu-sqemu-system-x86_64: warning: host doesn't support requested feature:    CPUID.80000001H:ECX.tbm [bit 21]
VNC server running on 127.0.0.1:5900

As you can see, although I haven't specified vnc option for qemu, it shows a message that I have to connect via vnc.

Is there any way to directly bring up the guest window? If I run that command on the main node (without ssh), then the guest window is shown quickly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.