1

According to Debian's RPi3 image wiki, I should be able to ssh into a Raspberry-Pi, with just the hostname. I shared internet from my Debian laptop, WiFi to the a Raspberry-Pi over Ethernet, but the hostname never resolved.

What kind of settings/configuration do either the client and server or the network need for LAN hostname resolution to work?

What do I need to install on the Pi so that MS-Windows can resolve the Pi's IP address when I want to access a web server hosted on it, for example? I think it's smbclient but I'm not sure.

  • 2
    They are not saying it is a given. They are saying if you have a local DHCP+DNS server configured in a certain way, it will work by name. You also have zeroconf ; also DNS configurations for more professional setting. smbclient if for SMB file shares, has nothing to do with it. Also, for a web server, you do not specify what you want to do with it, and whom is getting into it e.g. what is your goal. – Rui F Ribeiro Jan 5 at 12:48
  • @RuiFRibeiro, I just need the web server to be accessible over the LAN using its hostname. – Oxwivi Jan 5 at 12:59
  • for how many computers? – Rui F Ribeiro Jan 5 at 13:01
  • @RuiFRibeiro, less than 10. It's going be pretty much unmanaged, that's why I'm not considering a DNS which I actually know how to set up. – Oxwivi Jan 5 at 13:17
  • 2
    Can you please proof-read, and clarify (you talk about an it, a Debian laptop, a raspberry-pi, and a MS-Windows something. What is it? what are the relation ships. Also you mention wired ethernet, and wifi, what is the relationships (are they connected, how, …)? – ctrl-alt-delor Jan 5 at 13:26
2

Enable Link-Local Multicast Name Resolution (LLMNR) on the RPi. Edit /etc/systemd/resolved.conf and set LLMNR=true. Enable and start the systemd service system-resolved: systemctl --now enable systemd-resolved. No DNS server is needed, but name resolution only works on the local net. Make sure there are no duplicate hostnames on the LAN.

  • resolved won't conflict with NetworkManager that's managing everything by default right? If it doesn't, I'll just uncomment the LLMNR line. – Oxwivi Jan 6 at 9:01
  • And is there a way to test that LLMNR is functioning as opposed to other methods like Avahi? – Oxwivi Jan 6 at 9:02
  • Try pinging the RPi's hostname from the Windows machine. – Johan Myréen Jan 6 at 10:55
  • Well, I set it up in the target LAN. All devices are on 192.168.13.0/24 subnet. Pinging raspberrypi (default Raspbian hostname) or raspberrypi.local yielded no results. – Oxwivi Jan 10 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.