2

I am trying to get my system to use my Nvidia MX150 graphics card.

Problem:

Nvidia X Server settings shows a blank screen.

enter image description here

The driver manager shows that i'm using nvidia-driver-390 and also says "No proprietary drivers are in use"

enter image description here

What I've tried:

  1. sudo apt purge nvidia*
  2. sudo apt update
  3. sudo apt upgrade
  4. sudo ubuntu-drivers autoinstall

The output of inxi -G shows:

Card-1: Intel UHD Graphics 620
Card-2: NVIDIA GP108M [GeForce MX150]
        Display Server: X.Org 1.19.6 drivers: modesetting,nouveau (unloaded: fbdev,vesa)
        Resolution: [email protected]
        OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) version: 4.5 Mesa 18.0.5

What steps can I take to fix the issue at hand?

4
  • Is pressing the "Apply Changes" button out of question? Jan 5, 2019 at 12:55
  • It's greyed out implying it's already in use i'm assuming
    – Martin
    Jan 5, 2019 at 13:05
  • @Martijn.Z What happens if you click on any other option and then back on nvidia-driver-390, is now still the Apply button greyed out? Nov 30, 2019 at 15:09
  • @Martijn.Z Also, you do not mention in your question that you already use an Nvidia drivers PPA, which becomes obvious from the picture. Please take your time and improve on your question contents. Cheers. Nov 30, 2019 at 15:12

1 Answer 1

1

I had the similar problem on Linux Mint 19.2 with Nvidia MX150. Here is how I have managed to make it work:

  1. Uninstall all of the nvidia related packages
sudo apt-get purge *nvidia*
sudo apt-get autoremove
sudo apt-get update
sudo reboot
  1. Verify that all of the nvidia related packages have been removed
sudo apt list | grep nvidia
  1. Remove the ppa:graphics-drivers/ppa repository entry
sudo add-apt-repository --remove ppa:graphics-drivers/ppa
sudo apt-get update
  1. Reboot (optionally disable the secure boot in BIOS)
  2. Install the latest recommended nvidia driver using Driver Manager nvidia-driver-435 distro non-free recommended

  3. Reboot and check if the GPU is visible in the Nvidia X Server Settings or in the output of the nvidia-smi command. Also check this post if you cannot see the details of the MX150 in the X Server or in the nvidia-smi command output.


Hardware: Lenovo T480 with Nvidia MX150

11
  • Also, why don't you disable Secure Boot? Nov 30, 2019 at 14:42
  • No. It is the latest driver version listed (as of writting this comment) when I use the sudo apt install nvidia-driver- [tab] command
    – kasptom
    Nov 30, 2019 at 14:42
  • 1
    please post the output of apt-cache policy nvidia-driver-440, as I have the very same OS, and I don't see it in the official repository. Nov 30, 2019 at 14:44
  • 1
    Ok, now, may I suggest using an Ubuntu package with: sudo apt-get install nvidia-driver-435=435.21-0ubuntu0.18.04.2, please? Nov 30, 2019 at 15:21
  • 1
    I agree, but remember you can undelete once you get it working. Nov 30, 2019 at 19:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .