0

I am trying to install software-properties-common on my Debian 9. But i get the error which states

The following packages have unmet dependencies: software-properties-common : Depends: python3-software-properties (= 0.96.20.2-1) but it is not going to be installed Recommends: packagekit but it is not going to be installed E: Unable to correct problems, you have held broken packages.

I have tried many solutions like apt update -f (as suggested by most of the debian users) but nothing worked for me.

Here is my source.list file:

deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian-security/ stretch/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ stretch/updates main contrib non$

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free
  • you can use an iterative approach until the real problem is found. 1st round: apt-get -d install software-properties-common python3-software-properties=0.96.20.2-1 packagekit (you can leave packagekit alone it's only recommended) – A.B Jan 4 at 21:10
  • @A.B I had already tried this. I get the same error for python3-software-properties – Hashir Sarwar Jan 4 at 21:16
  • Maybe this happened after you did something special but didn't write in the question? Did you update (with apt update , not apt update -f which is illegal) before trying ? – A.B Jan 5 at 12:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.