1

I am currently changing my Linux client from Ubuntu 16.04 to Debian 9.6, and I am trying to setup LDAP client authentication to debian machine.

While setup, I noticed that the following command does not exist on debian

sudo dpkg-reconfigure ldap-auth-config

To setup Debian LDAP, I have no clue how to configure.

  • Thank you for pointing out. I just change some words. – user655563 Jan 6 at 9:27
  • I don't know what ldap-auth-config is, but on Debian you'll want to dpkg-reconfigure the nslcd package with your LDAP details, then libnss-ldapd for including it into the local name service switch and finally libpam-ldapd to enable the PAM LDAP module (if you need that). Equivalently, edit /etc/nslcd.conf, /etc/nsswitch.conf and /etc/pam.d/what-you-need, for example common-auth for overall coverage. – Ferenc Wágner Jan 6 at 11:25
  • @FerencWágner please post that as an answer. Comments are for asking for clarifications, answers should be posted as answers so the community can vote on them and the question can be marked as answered. – terdon Jan 6 at 13:31
  • How it doesn't exist? Can you post the actual output? – Braiam Jan 6 at 15:08
  • @terdon Done, although I'm genuinely unsure whether this is the type of answer the OP seeks. – Ferenc Wágner Jan 6 at 17:33
1

On Debian you'll probably want to apt install nslcd and configure it with your LDAP details (or dpkg-reconfigure nslcd if already installed), then install/(re)configure libnss-ldapd for including the LDAP data into the name database and finally libpam-ldapd to enable the PAM LDAP module, if you use PAM for authorization. Equivalently, edit /etc/nslcd.conf (then reload nslcd), /etc/nsswitch.conf and /etc/pam.d/common-auth (or some other service file if you don't need generic coverage across all PAM services). See also man pam-auth-update in case the defaults don't fit you.

Once the above works, consider apt install unscd for better performance, but don't forget that this cache will have only delayed consistency with your LDAP database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.