0

When I call make xconfig in my linux kernel source directory, I get the following error

scripts/kconfig/qconf  Kconfig
Gtk-Message: Failed to load module "canberra-gtk-module"
Qt: Session management error: None of the authentication protocols specified are supported
X Error: BadAccess (attempt to access private resource denied) 10
  Extension:    130 (MIT-SHM)
  Minor opcode: 1 (X_ShmAttach)
  Resource id:  0x142
X Error: BadShmSeg (invalid shared segment parameter) 128
  Extension:    130 (MIT-SHM)
  Minor opcode: 5 (X_ShmCreatePixmap)
  Resource id:  0x300000d
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x300000e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x300000e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x300000e

and the window which opens, titled Linux/x86 4.9.130 Kernel Configuration is just empty. That means I cannot use the Qt front-end for the kernel configuration. I have been using the make targets menuconfig and nconfig so far, but I would also like to be able to use the graphical Qt front-end as it is more convenient.

Note that in my Ubuntu that I have installed along-side Debian, it works. I have compared all Qt4-related packages installed under Ubuntu with those installed in Debian, and each package with qt in its name, except those in version 5.9.5 as they are Qt5, is also installed under Debian.

  • 1
    Just a thought: are you trying to run make xconfig as root? Don't do that. It's a bad idea even with make menuconfig. – Johan Myréen Jan 4 at 6:26
  • Thanks @JohanMyréen. Yes, as root, having switched to root with su. I just tried it as normal user, and it works. In Ubuntu I have always done it as root, after I've typed sudo -s. Why does it work as normal user? Also, why is make xconfig as root a bad idea. – Stefan Hamcke Jan 4 at 13:41
  • For security reasons, by default, root (or any other user) can't connect to a user's X server. As a rule of thumb, restrict your user privileges to the required minimum. Superuser powers is not needed to configure and compile software. If the permissions on a directory in /usr/srcis a problem, a better solution is to enable access to the user's group instead of running the whole build process as root. Only do the make modules_install and make install steps as root. – Johan Myréen Jan 4 at 15:24
  • @JohanMyréen I know you don't actually need root privileges for kernel configuration. On the other hand, in the manual /usr/share/kernel-package/docs/Kernel.htm in the kernel-package (for Ubuntu) package, the author argued "Login as root to do this type of administration. Some of the other kernel-building documents that I've seen make a big deal about what parts of the procedure can be done as a non-root user. I never bother with that. To me, kernel building and installing are administrative tasks, and I just stay root the whole time. It's simpler that way", which had convinced me. – Stefan Hamcke Jan 4 at 16:09
  • @JohanMyréen: Okay, say I want to use make xconfig as normal user, but with as few relaxations of the restrictions on the files in the directory as possible. How would I do that? I could change the group of all files to a group the user is a member of and allow write permission for that group, can't I? – Stefan Hamcke Jan 8 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.