0

I'm trying to install Arch with LVM encryption on my HP Spectre x360.

These are my installation notes.

I tried doing it these three ways

  • Using window's EFI part so here the EFI partition is nvme0n1p2 (replacing nvme0n1p5 with nvme0n1p2 from the notes)
  • Creating an extra EFI part along with window's which my notes cover exactly. (new EFI part is nvme0n1p5)
  • Completely wiping the NVMe drive. (Replace nvme0n1p5 with nvme0n1p1, nvme0n1p6 with nvme0n1p2, nvme0n1p7 with nvme0n1p3 from the notes)

Following is same for each of those approaches.

The first problem I encounter is after arch's install and arch-chroot /mnt.

When I'm trying to run this command grub-mkconfig -o /boot/grub/grub.cfg

Pressing return does nothing. The command just sits there executing forever (longest I gave it was around 22hrs).

I tried this workaround and while it gets that grub command running

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
done

It fails to detect Widnows in case I have it installed.

And finally it leads me to the root problem in the title.

Grub comes up before a 'decryption' prompt. (I'm not sure if this is supposed to happen because I have another machine where I followed exact same notes and it prompts me for volgroup password before showing any splash screen.)

And after I select Arch Linux from grub boot options, the boot gets stuck at Loading initial ramdisk. I gave it around 5hrs but no luck.

Also I tried installing debian too. But it gets stuck right after I press Graphical Install. The middle 'screen' goes blank and just sits there.

What could be the problem?

  • Partition: GPT - UEFI
  • Secure Boot OFF
  • Installation media created with 'rufus'
  • Windows installs just fine.
  • Your UEFI probably already has a boot menu to choose from (Windows should create an entry in it). If you don't need Grub for any other reason than to choose the OS, you can skip it in my opinion and create an entry in the UEFI boot manager directly using efibootmgr (you can check the already existing entries using efibootmgr -v). Can you paste the grub.cfg that works on your other machine using that same setup? – Pierre-Alain TORET Jan 3 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.