1

I'm trying to play .mp3 or .wav files by using aplay , I tried various flag formats to stop noise, such like -f S16_LE -c2 -r44100, -f S16_BE -c2 -r44100, -f S16_LE -c2 -r48000 -f cd 16 bit little endian,44100,stereo -f cdr 16 bit big endian,44100,stereo -f dat 16 bit little endian,48000,stereo I want to stop the noise and hear clear sound, how can I?

closed as off-topic by Stephen Harris, RalfFriedl, GAD3R, icarus, Sparhawk Jan 3 at 7:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Stephen Harris, GAD3R, icarus, Sparhawk
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What exactly are you hearing? Is it only "electronic" noise, or the expected sound overlaid with noise? What kind of audio hardware your system has, i.e. what is the output of aplay -l command? If your system includes PulseAudio, pacmd info might produce more detailed information. Also check your mixer settings: if your audio hardware includes a channel named "Loopback Mixing" or similar, try disabling it. It's implemented badly in certain sound chips and can cause extra noise to be injected into output. – telcoM Jan 2 at 12:10
  • hearing only electronic noise, INTEL 82801AA-1CH hardware, mixer setting is not eneble on loopback mixing – AlphaCoder Jan 2 at 12:59
  • Thanks for your help, Actually this media file was corrupted and it seems that .mp3 format is INVALID for aplay only work perfectly with .wav format – AlphaCoder Jan 2 at 13:14