1

In order to run flatpak applications (like Discord or Spotify) I currently have to export the $PUSLE_SERVER in my ~/.zshrc or ~/.bashrc like so:

export PULSE_SERVER=unix:/tmp/pulse-PKdhtXMmr18n/native

After reading this part of the pulse audio FAQ I believe I can get this working by using ~/.config/pulse/client.conf.

I have tried adding either of the following two lines to my ~/.config/pulse/client.conf:

default-server = unix:/tmp/pulse-PKdhtXMmr18n/native

And:

auto-connect-display = yes

NOTE: I tried the second because someone on the IRC suggested that flatpak may be looking at something related to X11 for the $PULSE_SERVER.

After trying an env | grep PULSE the $PULSE_SERVER does not appear to be being set. Furthermore neither of these approaches seem to have any effect (in saying that the first seemed to interfere with the session start as it stopped my polybar from starting, I have no idea why or how to debug this).

The main reason for wanting to define the $PULSE_SERVER elsewhere is I don't want to have to declare it in each shell and I would like to keep all the pulse config in one place.

I originally tried adding the above export to my ~/.xprofile (I use SDDM to start my session) however this stopped the pulse folder from being created in /tmp/.

Additional Info: I am running void linux with the bspwm window manager.

0

Usually you could simply export a variable in your shell config, which would get exported each time on start up too by :

export PULSE_SERVER="unix:/tmp/pulse-PKdhtXMmr18n/native"

then after that you could either source your shell config file by say :

source ~/.bashrc

or open up a new terminal so as to update the env.

now if you grep for PULSE, then env variable would popup.

  • Hey, that is what I am currently doing (as stated at the beginning of the question) this is actually what I am trying to move away from. – Otis Wright Jan 3 at 0:03
  • you tried to put it in the pulse config and also in shell configs and you said "env | grep PULSE" was futile. so i just wanted to point out that there is a chance that's because of the common mistake of not restarting terminal/not sourcing the corresponding file. – Yedhin Jan 3 at 1:33
  • I have said that my current solution is to have it in my .bashrc or .zshrc and this is what I would like to move away from, sorry when I was referring to env | grep PULSE I meant it was futile when using the other methods. – Otis Wright Jan 3 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.