1

My case is similar to some of the proposed solution in this question where on startup mc attempt to resolve & connect to hostname. Except, instead of accessing the hostname, the mc running on server instead attempt to access my local IP.

If I SSH directly to my server, the last line from strace mc will be :

connect(3, {sa_family=AF_INET, sin_port=htons(6000), sin_addr=inet_addr("139.X.X.X")}, 16

before it seem to hung up for a while and then load mc. 139.X.X.X is my local client IP. My server's IP is 5.x.x.x

If I reroute the SSH through my server itself, either using secondary SSH connection for socks proxy or connecting to OpenVPN running on the server, mc load up instantly.

Is there a way to just disable any attempt to connect at startup, or is there a way to trace where does my server decide to pass my client's IP to mc?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.