3

I have a USB stick with netinst version of Debian Wheezy (testing). I am trying to load a preseed file, named "preseed.cfg" in the USB root folder (same folder as initrd.gz). I use GRUB and my entry looks like this:

menuentry 'Debian Wheezy automatic install' {
  linux /vmlinuz preseed/file=/hd-media/preseed.cfg auto=true priority=critical
  initrd /initrd.gz
}

Now everytime the installer starts it says cannot find file:///hd-media/preseed.cfg. Will continue with manual install". Do I have the wrong syntax? Also, I thought any file named "preseed.cfg" will be detected automatically.

4 Answers 4

2

Here's the line I used for grub1 when I was doing this on Lenny using CDs.

append vga=normal initrd=/install.amd/initrd.gz preseed/file=/cdrom/preseed.txt debian-installer/locale=en_US console-keymaps-at/keymap=us --

Other than the fact that you're using grub2, it doesn't look significantly different.

You need to make sure that the path you're trying to use is actually the correct path. Does the USB installer mount itself to /hd-media? I haven't tried this with Wheezy (yet) but that doesn't feel right to me.

To check, start up the installer then switch to the shell console (I believe it's 4, so press ctrl+alt+4) then look around the system for your pressed.cfg file.

The file path that you list must match the exact file path of the preseed.cfg from the root of the booted installer.

1
  • Silly me, it was true that the usb was never mounted, because I dowloaded the netinst version instead of the hd-media version. Currently there is a bug in WHeezy install that makes the hd-media version hang when scanning for the ISO file under some circumstances, so I changed to netinst without thinking what implications it would get to the mounting process.
    – Rolle
    Commented Sep 27, 2012 at 8:41
1

Could you add rootdelay=60 to your boot parameter, to see if it works? Sometimes the kernel needs time to have USB devices detected, ready, drivers loaded and filesystems mounted.

0

I had the same problem and apparently the contents of the installation image (Debian Wheezy 7.3) was mounted under /cdrom/ instead of /hd-media/ - however, I did use unetbootin to create the USB-disk, which might affect the location of the mount.

0

Thanks all on this thread...

For debian-8.4.0-i386-CD-1.iso (32bits), installing on an old Toshiba Dynabook Satellite J40 (Pentium M 2GHz, single core) FROM the CDROM (700MB) disk and using the preseed file on an USB KEY, I succeed first, by following the advice to gain the terminal (BusyBox) using Ctrl + Alt + F2, with the "rootdelay=90"...

The USB KEY was mounted at "/media", so my config file was at "/media/file.cfg"...

The "/hd-media/file.cfg" DID NOT WORK FOR this particular notebook...

Then, the working option (for my case) is:

rootdelay=90 preseed/file=/media/file.cfg

I am not sure if it is the same for ANY PC or just this particular one...

*Also, the USB KEY is a "pre-historic" 256MB PQI with FAT16 format...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .