0

I'm using an ultrabook (Dell XPS13 9350) connected to a Razer Core V2, (which works wonderfully!) inside of which is an AMD Vega Frontier Edition (air-cooled). This part of the setup has never given me problems, and is very capable despite the limited Thunderbolt bandwidth.

The outputs to many system info commands are in a separate pastebin:

https://pastebin.com/RmMH4RZN

The problem is my LG UltraWide 34in second monitor (3440x1440, plugged directly into the Vega with a displayport cable), which only worked for a short period after I got it, before my distro (Solus) updated Xorg from version 1.19 to 1.20. It was also necessary, at first, to use these commands to start the screen (which came from the Arch Wiki: https://wiki.archlinux.org/index.php/PRIME):

xrandr --setprovideroffloadsink "Radeon Vega Frontier Edition @ pci:0000:08:00.0" Intel
xrandr --setprovideroutputsource "Radeon Vega Frontier Edition @ pci:0000:08:00.0" Intel
xrandr --output DisplayPort-1-2 --above eDP1

(eDP1 was, at one point, lvds1)

The display settings screens of Gnome, Mate, Budgie, and KDE have never shown the second monitor until the above commands were executed

After the update, the second monitor has never worked, and this is the state I'm in right now, using the above commands:

https://imgur.com/a/TUEXmVH

Also, I do realize that I could roll back the update and lock the version, but that would only be a band-aid, and something else will eventually break, so I would like to find a fix for the current version.

First I tried using Gnome with Wayland, which recognized that there was a second monitor right away, but also looked scrambled (only at 21:9 resolutions, 16:9 works fine in wayland), just like it does in the second picture above. Then I tried using Ubuntu, which had the second monitor working, but only on a reduced resolution. The native resolution still looked scrambled. While on Ubuntu, I installed the AMDGPU-PRO drivers, which never even recognized the second monitor, even after the commands above. I've also tried messing with the refresh rates, to no effect.

For a time, I dabbled in the xorg.conf.d folder, but I still haven't made much progress there, except for getting the external monitor's speakers to work at startup.

  • Did you try enabling Display Core? wiki.archlinux.org/index.php/AMDGPU#AMD_DC amdgpu.dc=1 kernel parameter AMD driver have gone through tons of turmoil I am just getting rid of the obvious – user1462442 Jan 6 at 23:06
  • Okay, after looking around a bit for the way Solus handles kernel parameters, I got it enabled. The good news is that when I type the setprovideroutputsource commands, the DisplayPort audio is available immediately, whereas before I had to restart pulseaudio. Otherwise, I still have to type the xrandr commands for the screen to be noticed, and the output looks just the same (with a different stretched pattern). Thanks, though, since I had never updated the kernel params in Solus before, I learned something. :) – TheLuigus Jan 10 at 4:26
  • You should test the latest kernel, but it looks like a Xorg regression. I would just report it to your distro bugzilla. dev.getsol.us/maniphest Either way, I would suspect proper eGPU support will be wayland only in the future. it seems like gnome added support in Gnome 3.32. Will be released in March phoronix.com/… – user1462442 Jan 10 at 15:51
  • Thanks, I'll look forward to the wayland update! In the mean time, I can make the screen work in 16x9 resolution, and report the bug. If you think of anything else I can try, do let me know. – TheLuigus Jan 12 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.