0

I installed my first distro: Void Linux, the version without any desktop environment. I got my wifi to work and the package manager (xbps) worked fine; I installed things like htop, i3, etc without problem. I booted my PC today and wanted to install git.

sudo xbps-install -S git

The same holds for any install command, such as:

sudo xbps-install -Su

I have the same problem in root or as a normal user.

It says:

Updating (some url) ...
Certificate verification failed for (some other url)
SSL_connect returned 1
ERROR: failed to fetch file (url of first line): Operation not permitted.

I did not change anything since yesterday, when it worked fine. I only found this on google:

https://github.com/voidlinux/void-packages/issues/14465 https://github.com/voidlinux/xbps/issues/224

For the first link, I do not have xtools and I do not have this file:

/var/cache/xbps/ca-certificates-20170717_2.noarch.xbps

so I cannot copy it. For the second link:

sudo update-ca-certificates

did not fix anything. It says:

0 added, 0 removed; Done.

I tried using another repo mirror but it doesn't seem to recognise those. I use https://alpha.de.repo.voidlinux.org/current

I don't know what to do from this point.

  • We can not help you with your desire to install git. Not being root, will have no effect on this desire. If this desire is elevated by install commands, then I would recommend avoiding them. – ctrl-alt-delor Jan 1 at 16:18
  • @ctrl-alt-delor Me wanting to install git was just an example, the whole package manager was broken, i could not install anything. But it has been solved by beginner6789's answer, apparently the DE server is just broken. Also I do not understand what you meant with your last sentence about install commands? – ocdy1001 Jan 1 at 16:26
  • Yes I was 100% sure that what you said was not what you meant. But that is what you said. – ctrl-alt-delor Jan 1 at 16:30
3

This happened to me too. There is a problem with the de.repo.voidlinux.org certificates.

The repositories can be changed from the default by copying the /usr/share/xbps.d/00-repository-main.conf file to /etc/xbps.d/ directory and editing the repository for example:

repository=http://alpha.us.repo.voidlinux.org/current

I changed from https to http and from the de to us repo and xbps is working now. Your file might be different for other platforms so just edit the repo part as appropriate.

I am sure this is just a temporary problem.

EDIT: Repo solved. DE repo is back and now working with https.

1

You should also check your local date/time because if it differs too much the server certificate is also treated as invalid.

This happens for example if you setup void-linux on a raspberry-pi where no hardware clock is available so your local date will be something like 01-01-1970 00:00:01. In this case a xbps-install -Suv will show a certificate error. Setting the correct date via the date command will fix the problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.