0

I'm running on Antergos with Gnome 3.30.2. Right now I have English and Russian keyboard layouts, they work fine.

$ dconf read /org/gnome/desktop/input-sources/sources 
[('xkb', 'us'), ('xkb', 'ru')]
$ dconf read /org/gnome/desktop/input-sources/xkb-options 
['grp:caps_toggle', 'grp_led:caps', 'compose:ralt']

I want to switch to ruu variant of ru. If I do

$ setxkbmap -layout "us,ru" -variant ",ruu" -option "grp:caps_toggle,grp_led:caps,lv3:ralt_switch"

everything works as expected, but if I do

$ dconf write /org/gnome/desktop/input-sources/sources "[('xkb', 'us'), ('xkb', 'ru+ruu')]"

layout indicator disappears from the top bar and I can't switch layouts. It behaves like if I set some non-existing layout, although it exists, can even be set through GUI (with "Show Extended Input Sources" enabled) and works with setxkbmap.

  • fwiw, I can't reproduce this on archlinux+gnome3; it works fine (the layout indicator updates in real time every time I run variations of your command in terminal). – don_crissti Jan 1 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.