0

I have an issue with my wired ethernet : After i plug it, the internet connection seem to be ok (ping at google.com --> OK), **but when i go to a website, after loading the first page, the connection is broken.

Config : Linux mint 18.2

sudo lshw -C network

 *-network
   description: Ethernet interface
   produit: AR8161 Gigabit Ethernet
   fabriquant: Qualcomm Atheros
   identifiant matériel: 0
   information bus: pci@0000:04:00.0
   nom logique: eth0
   version: 08
   numéro de série: 10:bf:48:28:20:4a
   taille: 1Gbit/s
   capacité: 1Gbit/s
   bits: 64 bits
   horloge: 33MHz
   fonctionnalités: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=alx duplex=full ip=192.168.1.11 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
   ressources: irq:30 mémoire:f7800000-f783ffff portE/S:d000(taille=128)

ifconfig show increasing number of erros in packet, and ping doesn't respond anyway.

eth0      Link encap:Ethernet  HWaddr 10:bf:48:28:20:4a  
          inet adr:192.168.1.11  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::443a:ead3:32f:d0f7/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:3450 erreurs:2036 :0 overruns:2036 frame:0
          TX packets:862 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:1067220 (1.0 MB) Octets transmis:138864 (138.8 KB)
          Interruption:19 

On the same laptop, I have a Windows boot and the wired ethernet works fine. Wifi connection is okay on both Windows and Linux Mint.

3
  • We will need more info (don't know what). It won't be related to loading a page. You seem to have a layer 2 problem, but loading a page is at level 4 or 5 or 6 ish. A page load can involve many connections. Jan 1 '19 at 11:39
  • Does dmesg give any related messages?
    – wurtel
    Jan 2 '19 at 9:31
  • hi, I don't think there is any related messages dmesg [ 1488.478859] alx 0000:04:00.0 eth0: NIC Up: 1 Gbps Full [ 1488.479182] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    – JB D
    Jan 7 '19 at 8:58
0

Solved thanks to : https://forums.linuxmint.com/viewtopic.php?f=150&t=226626&p=1196004&hilit=AR8161#p1196004

Set MTU to 8192 with

sudo ifconfig eth0 mtu 8192

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.