I had created physical volume earlier i.e. /backup, /ndasdb, /processor, /latro.

Don't know what exactly happened, but /ndasdb is not showing in any of this output result:

Pvdisplay, Vgdisplay, and lvdisplay. rest 3 are showing.

I can see the lun in multipath -ll (ndasdb is there)

I tried to recreate it with pvcreate /dev/mapper/ndasdb but its gives me this error:

WARNING: gfs2 signature detected on /dev/mapper/ndasdb at offset 65536. Wipe it? [y/n]: n
  Aborted wiping of gfs2.
  1 existing signature left on the device.

Is it true if I do yes it will delete my all data? Is there anyway to bring my drive back without loosing any data?

lsb output


Is it true if do yes will delete my all data?

Yes, you are right because you will write LVM data inside the disk.

is there anyway to bring my drive back without loosing any data.

As pvcreate command detected a GFS2 filesystem intact in the disk and assuming it can be mounted, you can proceed as follows:

  1. Create a mount point and a backup folder:
    mkdir /mnt/{mountpoint,backup}
  2. Mount the disk:
    mount -t gfs2 /dev/mapper/mdasdb /mnt/mountpoint
  3. Copy the data in /mnt/mountpoint folder to /mnt/backup:
    cp -r /mnt/mountpoint/ /mnt/backup/
  4. Now your data should be in /mnt/backup folder.
  • Hello thanks for reply, i could not understand well. please how will i mount it? what info are you asking to extract ? please i would be really greatful to you if could tell me the step by step process. thanks in advance. – Himanshu Dua Jan 1 at 9:05
  • if i am getting you right i trid to mount with this, mount /dev/mapper/ndasdb /ndasdb. it says "mount: mount(2) failed: No such file or directory " please let me know how can i mount and take my info to a backup location. – Himanshu Dua Jan 1 at 9:20
  • @HimanshuDua I have modified the answer. Waiting for your feedback. – Manuel Florian Jan 1 at 20:03
  • i tried do use this command.mount -t gfs2 /dev/mapper/ndasdb /mnt/ mount: mount(2) failed: No such file or directory. it giving me this error – Himanshu Dua Jan 2 at 7:40
  • It looks like /mnt folder doesn't exit. Did you run the Step1 successfully? Please provide the output of ls /mnt. – Manuel Florian Jan 2 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.