I have a network share named dreambox on C:\dreambox that is shared with the group Everyone in Windows. I have mounted it to /hdd on a Linux-based STB with OpenDreambox (OpenEmbedded) using Telnet (PuTTY).

I have done so to enable the STB to record TV show to my PC without a dedicated eSATA disk drive.

I now wish to undo this, because I want to use a different PC for this and stop using this one.

This is the command I have used after connecting to the box over telnet and logging in:

cd /
umount -t cifs

This command was accepted. But I was still able to press the Record button on the STB remote control and get the popup menu for recording. But if I chose to record the REC symbol would start flashing on the Info-bar but there were no files actually recorded to my network share. So it kind of... only kind of... worked...

Also, when I stopped the recording I got a GSOD (green screen of death) showing me some basic crash information and told me to send the log to the manufacturer to their e-mail address. It also stated that it would have to reboot. But I don't think it actually rebooted. So when I went to Menu, Standby/Restart, and choose Restart I could see the gears animation as if it was loading settings and then I got the same kind of GSOD again. I don't think it fully rebooted at all. I have done it repeatedly and got the GSOD every time. I then switched it off from power and put it back on, and after booting I had the same problem again.

These are the steps I have done to enable this:

1. PuTTY start
2. Connect to
3. Log in as root
4. cd /
5. mkdir /hdd/movie
6. mount -t cifs -o username=*,password=* // /hdd
7. cd /hdd
8. ls (showed nothing - empty folder)

Also, the Linux box is running BusyBox, and from what I understand, this is the package that gives it the shell command. I mention this because this shell doesn't seem to support all shell commands found on a regular Linux distro.

I did try this command first:

umount -t cifs -t cifs -o username=*,password=* //

Is this the proper syntax?

This is the same command as the one I used to mount, only this is the umount command to unmount. And it didn't work, it didn't find the directory, file, or device (not sure of exact word). So I decided to unmount everything cifs (as seen above), and it worked, but caused the Linux box to act up.

I have now done the same command again:

mount -t cifs -o username=*,password=* // /hdd

It got mounted, and I no longer get any GSOD and I can record once again.

But how do I stop it for good?...

I think it has something to do with bad references. Something is referring to my network share which is no longer there when I unmount it, which in turn causes Linux to start acting up.

FWIW, this is the content of my fstab file in /etc/fstab:

rootfs               /                    auto       defaults              1 1
proc                 /proc                proc       defaults              0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
usbfs                /proc/bus/usb        usbfs      defaults              0 0
/dev/mtdblock2       /boot                jffs2      ro                    0 0
tmpfs                /var                 tmpfs      defaults              0 0
tmpfs                /tmp                 tmpfs      defaults              0 0
/dev/sda1            /media/hdd           auto       defaults              0 0

I did use a different set of commands in my first attempts to mount the share in the box. And to make it mount on reboot I have edited this file. But I have undone those changes, so this should not have any effect anymore. What you see here above is what the fstab file looks like by default.

Oh right... the /hdd actually redirects to /media/hdd. So the movie folder I created in the process is actually in /media/hdd/movie and not /hdd/movie (step 5. mkdir /hdd/movie).

1 Answer 1


I sorted it out!

cd /
fuser /hdd
kill 6088
shutdown -r now

I'm not sure if it's necessary to cd to the root but I have done so anyway. The fuser /hdd gives you the PID (process id) of the process that's using this device or folder. In this case it was 6088. The kill command followed by the PID stops that process.

The shutdown -r now command reboots the system. However, it is not necessary to use, you can simply get the remote control and go to Menu, Standby/Restart and choose Restart. These steps are for Dreambox on Enigma2, your STB might be different. It should reboot normally, without any errors.

I did first go to /media/hdd over FTP and deleted the contents of the folder movie and then the folder itself. From the looks of it, it was trying to record to the Windows share that I had mounted, and since it was unmounted it tried to record to its internal memory which is only 64 MB. And it gets full fast, so it was basically out of memory. I think this one of the main reasons for crashing, even on reboot. So you might also want to get rid of this stuff first.

Rebooting works normally now, and when I press the Record button it just states that there is no HDD connected, which is normal.

Feel free to give me an answer that does not involve fuser and kill commands. What is the proper way of unmounting a network share on Linux? For the time being, this works OK for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .