Seems like i today updated my system. After system reboot i can see Login screen. But after login with my user, booth screens turn in black and after ~30-45 seconds i get kicked back to login screen. By pressing CTRL+ALT+F2 from Login screen i can get into terminal mode and can log in. I tried to run startx with no luck. After some loading got bunch of output. (See linked img's) Then i tried sudo startx and got logged into GUI but as root user (not what i want). Then i removed current Nvidia driver 410.XX and installed new 4.15.XX from Nvidia website. Still the same issue. I tried to remove RHGB and to update EFI grub config. Still nothing. What i am doing wrong? enter image description here enter image description here

  • Check permissions on files in your $HOME and also ensure there is free disk space Dec 30, 2018 at 17:29
  • I"m not sure what was supposed to be at those links but they do not work for me. If they are images, then you should upload them here, rather than linking to external image hosting sites. Dec 30, 2018 at 18:55
  • I added images. I already tried to remove shell extensions. To add .Xauthority file with chown user:user and 600. (it was not there when i checked first time). I installed language packs - bugzilla.redhat.com/show_bug.cgi?id=1573683#c15
    – Dzintars
    Dec 30, 2018 at 22:19
  • Ouh man... by some misterious reason owner of /home/user was root:root. I did chown -R user:user /home/user and looks like at least startx works as expected. Can log in now.
    – Dzintars
    Dec 30, 2018 at 22:36
  • @Dzintars it may be good to answer your question for those who come here with similar problem.
    – peterph
    Dec 31, 2018 at 15:59

1 Answer 1


I will post answer on my own. 1) Check /home permissions by entering ls -la /home in your terminal. If you see that owner of /home/user directory are not your user but for example root then you should change it to be your user. 2) Change ownership of /home/user directory by entering chown -R user:user /home/user in your terminal. This will recursively change ownership for all files and sub-directories of /home/user directory for your regular user. Check ownership again by entering command above. 3) Run startx and you should be back to live. :) 4) Probably can do full system reboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .