4

I have mentioned -g option along with -Wall in the Makefile.

When I run gdb onlineSunday, I get:

Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_dds.so
Try: zypper install -C "debuginfo(build-id)=a84a1969b9a69361b10f26814c0958717c48d671"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_eps.so
Try: zypper install -C "debuginfo(build-id)=81e00b39aa9b3f7af23bad9d5bcef9f7cfe6333e"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_exr.so
Try: zypper install -C "debuginfo(build-id)=0101355f5aa48dca9cf2723c94d1a4b7eb21e2ec"
Missing separate debuginfo for /usr/lib64/libIlmImf.so.6
Try: zypper install -C "debuginfo(build-id)=f26997841c2902a0db04726d4018640cf367101e"
Missing separate debuginfo for /usr/lib64/libIex.so.6
Try: zypper install -C "debuginfo(build-id)=2af205c15500875184d2b8519dbe01404bdfb3ae"
Missing separate debuginfo for /usr/lib64/libHalf.so.6
Try: zypper install -C "debuginfo(build-id)=5134d1c2dc3c6ea90b5eeabd518eb746c853b87c"
Missing separate debuginfo for /usr/lib64/libIlmThread.so.6
Try: zypper install -C "debuginfo(build-id)=ebb1d12661df5bbf0dd39c7c717cd197ada35d98"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_jp2.so
Try: zypper install -C "debuginfo(build-id)=c1c25e24a14a9ec9163d623c699b6b53b7a1aabc"
Missing separate debuginfo for /usr/lib64/libjasper.so.1
Try: zypper install -C "debuginfo(build-id)=d521bb2892ccef13f28afaa82c0ef48433e46ca5"
Missing separate debuginfo for /usr/lib64/libjpeg.so.62
Try: zypper install -C "debuginfo(build-id)=c3638afbf013f8e33beaa3dc12f4d2dbdb3f8602"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_pcx.so
Try: zypper install -C "debuginfo(build-id)=d1b443e7a29dd71a2519d852057c814bcfc9c30b"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_pic.so
Try: zypper install -C "debuginfo(build-id)=4d533a04cab4426beaf2ae3c89eb2e026e5e1f81"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_psd.so
Try: zypper install -C "debuginfo(build-id)=39ff79c31ae413ebac40eb8baef54ac524886e57"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_ras.so
Try: zypper install -C "debuginfo(build-id)=7ecf3f8738c8cfacb14b6e54b53526346513dc8b"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_rgb.so
Try: zypper install -C "debuginfo(build-id)=fc5d771438bc73014a4d551eb3b996043729c625"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_tga.so
Try: zypper install -C "debuginfo(build-id)=9dd675ab0b9906bb234a90f8f4e9e65b7b6fbf63"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_xcf.so
Try: zypper install -C "debuginfo(build-id)=2bfe0932ffdf6473010f792e1bde388881fdaff0"
Missing separate debuginfo for /usr/lib64/kde4/plugins/imageformats/kimg_xview.so
Try: zypper install -C "debuginfo(build-id)=6ba5f69301b600fe14553d99ef495df1d08ba379"
"ReferenceError: Can't find variable: displayMapAndClick on line:1 Source:undefined" 
Missing separate debuginfo for /lib64/libnss_files.so.2

GDB version:

anisha@linux-trra:~> gdb -version
GNU gdb (GDB) SUSE (7.2-3.3)

anisha@linux-trra:~>

The package:

linux-trra:~ # cnf debuginfo-install

Program 'debuginfo-install' is present in package 'yum-utils', which is installed on your system.

Absolute path to 'debuginfo-install' is '/usr/bin/debuginfo-install'. Please check your $PATH variable to see whether it contains the mentioned path.

linux-trra:~ #

The system:

linux-trra:~ # cat /etc/issue && uname -a
Welcome to openSUSE 11.4 "Celadon" - Kernel \r (\l).

Linux linux-trra 2.6.37.1-1.2-desktop #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 x86_64 x86_64 x86_64 GNU/Linux

linux-trra:~ #

This is what I did:

linux-trra: # zypper install -C "debuginfo(build-id)=a84a1969b9a69361b10f26814c0958717c48d671"
Retrieving repository 'Updates for openSUSE 11.4 11.4-0' metadata [done]
Building repository 'Updates for openSUSE 11.4 11.4-0' cache [done]
Retrieving repository 'devel:languages:R:patched' metadata [done]
Building repository 'devel:languages:R:patched' cache [done]
Loading repository data...
Reading installed packages...
No provider of 'debuginfo(build-id) = a84a1969b9a69361b10f26814c0958717c48d671' found.
Resolving package dependencies...

Nothing to do.

linux-trra: #

What to do now?


linux-trra: # zypper ar -f -n "openSUSE-11.4-Debug" http://download.opensuse.org/debug/distribution/11.4/repo/oss/ repo-debug
Adding repository 'openSUSE-11.4-Debug' [done]
Repository named 'repo-debug' already exists. Please use another alias.

linux-trra: # zypper ar -f -n "openSUSE-11.4-Debug" http://download.opensuse.org/debug/distribution/11.4/repo/oss/ repo-debug-update
Adding repository 'openSUSE-11.4-Debug' [done]
Repository named 'repo-debug-update' already exists. Please use another alias.

linux-trra: # 
2

Enable and refresh the debug repos.

http://download.opensuse.org/debug/distribution/11.4/repo/oss/

http://download.opensuse.org/debug/update/11.4/

 zypper ar -f -n "openSUSE-11.4-Debug" http://download.opensuse.org/debug/distribution/11.4/repo/oss/ repo-debug
 zypper ar -f -n "openSUSE-11.4-Update-Debug" http://download.opensuse.org/debug/update/11.4/ repo-debug-update

EDIT: After you've enabled the repos, then you should be able to install your packages.

2

You can debug a program even if not all the libraries have debuginfo, you just won't be able to follow into the library in terms of source code. Most of the time the problems aren't in the library anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.