0

"set linenumber" doesn't seem to be working. GNU nano version 2.5.3. LinuxMint 18.02 (old because my Ubuntus -- 17.04 and 18.04 -- are broken.) Is there another way to do it?

  • 2
    According to the changelog, the linenumbers option was added in version 2.7.1-1 – steeldriver Dec 28 '18 at 2:07
  • Does askubuntu.com/questions/73444/… help? – Stephen Harris Dec 28 '18 at 2:08
  • No it does not. They suggest exactly that thing that doesn't seem to work. I invite you to read my OP again. I meant ""set linenumber" doesn't work." – Steve Wright Dec 28 '18 at 3:06
  • I have since upgraded my nano to 2.9.3 (thanks to a deb I found for Ubuntu 17.04 online somewhere). I had the installer script keep my edited nanorc, which included the added "set linenumber" as well as an uncommented "set constantshow." Of course all the foregoing were displayed in a nano Without line numbers. – Steve Wright Dec 28 '18 at 3:09
  • 1
    AFAIK the option is linenumbers, not linenumber – steeldriver Dec 28 '18 at 3:39
2

Just open your file with line number option:

nano myfile.sample -l

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.