11

I change to Linux Mint about 2 days ago. And I feel uncomfortable when I put the 'sudo password', because I used to see nothing and now I saw "*****".

1
  • 1
    Are the asterisks showing up when you run sudo something, or when logging in as root, or???
    – Jeff Schaller
    Commented Dec 27, 2018 at 19:32

3 Answers 3

8

LinuxMint added the behavior in /etc/sudoers.d/0pwfeedback.

You could simply do like I did, delete the file as it contains only that adjustment:

sudo rm -rf /etc/sudoers.d/0pwfeedback
2
  • 3
    See @Entropy0's answer bellow for a more permanent and solid solution. Commented Dec 26, 2019 at 11:08
  • @Entropy0's answer should be the accepted answer because it will work after system upgrades. This solution will only work until you upgrade your system.
    – axiopisty
    Commented Jul 16, 2020 at 17:42
7

Use visudo to remove any mention of 'pwfeedback' in your sudoers file. If on, it's usually under one of the 'Defaults' lines.

You can also add a ! before any instance of pwfeedback in the file to explicitly disable it if you need finer-grain control.

Edit: If you're uncomfortable using vi you can also specify the editor with something like EDITOR=nano sudo -E visudo

7

The accepted answer of simply removing /etc/sudoers.d/0pwfeedback will work precisely until the next update to mintsystem puts that file back in place.

The way to revert to the old behavior that is recommended by the person responsible for the new one is to override the setting in a different file that gets read later:

echo 'Defaults !pwfeedback'|sudo tee /etc/sudoers.d/9_no_pwfeedback

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .