0

I have configured apache web server on fedora 29 , perl script that generates web page with current NIC information (state , speed , mac , etc.) and traffic graph. Script generates the web page and shows the information about the interface but the graphic can not be visualized .When I run it in the terminal generates the graphic and saves it into the dedicated dir, but when I run the script via HTML button it's not working.
error_log says ERROR: Could not save png to '/var/www/grafika/graphHour.png'. User angel and group apache have rwx , "others" have r-xto all directories and files.


Directories' permissions :

drwxrwxr-x. 2 angel apache 110 Dec 27 15:47 cgi-bin
drwxrwxr-x. 2 angel apache  94 Dec 27 15:47 grafika
drwxr-xr-x. 2 angel apache  41 Dec 23 18:26 html

Script's permission:

-rwxrwxr-x. 1 angel apache 2323 Dec 27 15:47 networkPage.cgi

  • 2
    Do you have SELinux enabled (getenforce)? If so, have you created rules to allow web apps to write to this directory? – Stephen Harris Dec 27 '18 at 14:38
  • Not exactly ,I've tried to make it in permissive mode just for test , and did not work . – Angel Dec 27 '18 at 14:42
  • 1
    Does a file with the same path & name already exist from manual testing, where the permissions would prevent over-writing it? – ivanivan Dec 27 '18 at 15:53
  • No , i deleted the files that were created . – Angel Dec 27 '18 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.