2

I have postfix + dovecot + pgsql. All has been working. Recently I've changed something in the config to combat spam. Now I see this in the logs:

localhost postfix/smtpd[2299]: warning: restriction `reject_authenticated_sender_login_mismatch' ignored: no SASL support 

localhost postfix/smtpd[2299]: warning: restriction `reject_unauthenticated_sender_login_mismatch' ignored: no SASL support 

localhost postfix/smtpd[2299]: warning: restriction `reject_authenticated_sender_login_mismatch' ignored: no SASL support 

localhost postfix/smtpd[2299]: warning: restriction `reject_unauthenticated_sender_login_mismatch' ignored: no SASL support 

But!

$ postconf -a
cyrus
dovecot

And

$ ldd /usr/sbin/postfix | grep sasl
    libsasl2.so.3 => /usr/lib/libsasl2.so.3 (0x00007f9508e75000)

If I remember correctly, I installed postfix via "pacman".

Why the warning and how to fix it?

upd1:

sudo postconf | grep -i smtpd_sasl

smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = no
smtpd_sasl_exceptions_networks =
smtpd_sasl_local_domain =
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous, noplaintext
smtpd_sasl_service = smtp
smtpd_sasl_tls_security_options = noanonymous
smtpd_sasl_type = dovecot

upd2:

in master.cf I've found this:

 smtp      inet  n       -       n       -       -       smtpd
       -o smtpd_sasl_auth_enable=no

Can this be the reason?

upd3:

also:

submission inet n       -       y       -       -       smtpd
    -o syslog_name=postfix/submission
    -o smtpd_tls_security_level=encrypt
    -o smtpd_enforce_tls=yes
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_sasl_type=dovecot
    -o smtpd_sasl_path=private/auth
    -o smtpd_sasl_security_options=noanonymous
    -o milter_macro_daemon_name=ORIGINATING
    -o smtpd_sasl_local_domain=$myhostname
    -o smtpd_client_restrictions=permit_sasl_authenticated, reject
    -o smtpd_recipient_restrictions=permit_sasl_authenticated, reject
  • But are they enabled? Please add the contents of postconf | grep -i smtpd_sasl. In my case, with dovecot, I have these 3 values specifically set: smtpd_sasl_type = dovecot smtpd_sasl_path = private/auth smtpd_sasl_auth_enable = yes – Stephen Harris Dec 26 '18 at 20:38
  • Sasl is a little bit funny on Postfix, you need to use saslauthd and configure them to work together. Sometimes surprising error messages are possible, but it can be done. A strace would be highly useful. – peterh Dec 26 '18 at 21:22
  • @StephenHarris see my update – nylypej Dec 26 '18 at 22:01
  • @peterh I don't understand – nylypej Dec 26 '18 at 22:01
  • Is the postfix user in the sasl group? ... or said another way... The postfix user needs to be able to access the dovecot sasl unix socket... see here – RubberStamp Dec 27 '18 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.