6

I am trying to install kernel headers version 4.14.71-v6 (uname -r) for Kali Linux. I already did the common commands...

apt update
apt upgrade
apt dist-upgrade
apt install linux-headers-generic
alt install linux-headers-$(uname -r)

...with and without option -y

Also did reboots. I searched the repos by apt search 4.14. I took a look onto http://http.kali.org/kali/pool/main/l/linux/, no success at all.

I've seen on http://http.kali.org/kali/pool/main/l/linux/ are kernel-headers for 4.18 and 4.19, but the upgrade is distributing versions only up to my 4.14.x

Does anybody have an idea what to do?

  • 7
    Everyone: please stop blindly voting to close Kali questions as dupes of the "why is Kali hard" one. The OP is showing effort, and asking a question that is on topic. – terdon Dec 26 '18 at 17:48
  • 1
    I notice that Kali provided kernels all have "-kali" in their name. How come yours has "-v6" instead? Was it provided by Kali in the first place? – A.B Dec 26 '18 at 20:01
  • Is it your issue that your system doesn't upgrade the kernel to 4.18 when you do the updates, therefore you are trying to install the old kernel headers (4.14) to match your current kernel? – Paul H. Dec 26 '18 at 20:42
  • 1
  • 1
    Please edit your question with the output of uname -a – Rui F Ribeiro Dec 26 '18 at 22:01
6

You are not finding the headers for your kernel version, in the official distribution repository, because you are dealing with a Kali setup using a custom made kernel version.

Whist we do not have all data, from you uname -r, it leds me to suspect it was made using these scripts/tools https://github.com/Re4son/re4son-kernel-builder ; it also leads me to speculate, after a bit of detective work, that maybe you have a Raspberry PI/ARM v6 device.

In this case, the easier option is either to reinstall a new version, or even better, choosing a more user friendly Linux distribution.

  • 1
    Thank you. You're right. It's the rpi0-version. I found another way installing the Re4son-kernel. It got headers installed by default. – Hendrik Jaenzoffski Dec 26 '18 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.