0

I've tried to install Gearman from source on Alpine, but it's gives an error:

configure: error: Please install libgearman

I tried to apk search libgearman, with no result, but in Ubuntu there is libgearman-dev and in CentOS libgearman-devel.

Then I tried to install Gearman using the command pecl install gearman, but it's gives the same result.

Note: I'm using php56 on latest Alpine container.

Is there any workaround that I'm missing?

2
  • have you tried apk add gearman-dev? Commented Dec 26, 2018 at 21:13
  • when i try to install gearman-dev, it's gives error result --> # apk add gearman-dev ERROR: unsatisfiable constraints: gearman-dev (missing): required by: world[gearman-dev] / # Commented Dec 27, 2018 at 2:19

1 Answer 1

0

Gearman is currently only available in the edge/testing repository, which is considered experimental, but may be enough for your needs (see here for package details and availability).

For installing Gearman, add the edge repositories to your /etc/apk/repositories file and update your apk database:

echo http://dl-cdn.alpinelinux.org/alpine/edge/main >> /etc/apk/repositories  
echo http://dl-cdn.alpinelinux.org/alpine/edge/community >> /etc/apk/repositories  
echo http://dl-cdn.alpinelinux.org/alpine/edge/testing >> /etc/apk/repositories
apk update

Then, install the Gearman packages with:

apk add gearman-dev gearman-libs
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .