0

I have ubuntu 16.04 on my laptop. It was working good until few days ago.

The system won't boot. It logs ACPI errors and then kernel panics:

ACPI Error: No handler for Region [RAM_] (       (ptrval)) [EmbeddedControl] (20170831/evregion-166)
ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.EC0._REG AE_NOT_EXIST

I disabled acpi by setting acpi=off and it boots - everything seems to work fine. I however need acpi to run windows and ofc not waste power.

To narrow down my search I unplugged all unecessary devices (including hdd) - I only left keyboard and obviously things that are soldiered to motherboard (cpu, gpus etc.). I inserted new RAM and tried different slot. I installed fresh ubuntu on usb stick and the same problem is present. The system will only boot with acpi disabled.

I educated myself a bit about ACPI and took a close look at the ACPI error. Is it possible that operating system is reading ACPI code provided by hardware (bios?) and tries to execute it but for some reason the code is corrupted and cannot execute a _REG method?

If my assumption is it possible that BIOS memory went bad and I can correct it by flashing BIOS? I tried to do that but DELL provide BIOS flashing tool only for windows but windows wont boot without ACPI (I just get random blue screens). Windows usb stick won't boot too (requires acpi too). Do you have any suggestion how to flash BIOS without windows (I can run dos and ubuntu)? Do you know any other reasons causing ACPI hardware failures (I am pretty sure its hardware since both linux and windows wont boot with acpi enabled)?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.