-6

I want to see the message inside this binary file:

]�$�r�ux����f��aY64QH���K�z{������y�ߗ��y�m����Ǖ�} ��cy@^��+|�%E(H��*�I�P�����7��8�=$�.�`ïc�
                                                                                                     !w|����7L�
                                                                                                               I4�Rԗ%�7F���$����a�Z�(�Y��1  ��4Y���C'�z��������^�\�-��-�hU��ʺ^KC�7������.DΖB/�����dB�3_��Ac�LȊ��R���[���l�(p���<g9�$����M�]�9�
                                      ��Q����Ƶ�i���N֕[c`�$;��hy8�S�
�bJ���T�����w_6�C;�Z�                                           �4��ˋ�Řog�$�:�F���l�+��6�o-� ����Q�=��#�O|a\
                        �z�����J;)<�vd��o� ��U�ә��|�Sţ6�����m=�:i�Y�����G�fJEt�*x����khC�>�
                                                                                                 |0��*At}�ao�mj[L��d�vϻ�

Does anyone have any idea how to do this?

I tried with xxd myfile but I didn't see the message.

closed as unclear what you're asking by Rui F Ribeiro, Gilles, msp9011, Thomas, sam Dec 27 '18 at 15:53

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can you add the output of file filename? – Haxiel Dec 26 '18 at 12:49
  • @Haxiel myfile: LZMA compressed data, non-streamed, size 548 – gogumartalogu22 Dec 26 '18 at 12:51
  • 1
    Please edit your question and include that information. That is essential. – terdon Dec 26 '18 at 12:51
  • 2
    What even makes you think that it's encrypted? And if it's encrypted, how do you hope people to decrypt it? And how do you hope people to help you when you post binary content into a text field, which removes most of the information? If you want help to figure out what this file is, tell us in what context you got it and post actual content, not butchered content. – Gilles Dec 26 '18 at 20:10
2

If your file is compressed using lzma (often xz --format=lzma), you can use that tool to decompress it. For example:

$ echo "hello world" > file
$ lzma file
$ cat file.lzma 
]���������4I���:3_��    �/���t

Now, read it it:

$ lzcat file.lzma 
hello world

Or decompress it:

$ unlzma file.lzma
$ cat file 
hello world

Or:

xz --format=lzma --decompress file.lzma
  • when i try this: xz --format=lzma --decompress file.lzma ==format he gave me this xz: myfile: Filename has an unknown suffix, skipping – gogumartalogu22 Dec 26 '18 at 12:59
  • @gogumartalogu22 does lzcat myfile work? If it does, then just run mv myfile myfile.lzma and then you can run xz --format=lzma --decompress myfile.lzma – terdon Dec 26 '18 at 13:00
  • it doesn`t work, can u show the message from my binary file please – gogumartalogu22 Dec 26 '18 at 13:06
  • 1
    @gogumartalogu22 no, you need to run it. I can't copy the data, that doesn't work. Please edit your question and show us the commands you tried and their output. – terdon Dec 26 '18 at 13:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.