11

How to set the behavior of gnome-shell workspaces (static instead of dynamic) via dconf?

I configured i3 style keyboard shortcuts to switch to specific workspace with Super+<num> but gnome-shell creates workspaces dynamically, so I can not switch directly to 4th workspace to run programs there if workspace 3 and 4 are not created.

3
  • @don_crissti Can this extension be just a javascript that I can paste into subdir of my home folder? Dec 26, 2018 at 3:26
  • Found extensions.gnome.org/extension/12/static-workspaces that says that extension is not required anymore and GNOME Tweak Tool can be used. Does it save configuration with dconf? Dec 30, 2018 at 7:38
  • Oh, my bad... looks like somewhere along the way they've decided to support this via dconf keys. Dec 30, 2018 at 12:57

1 Answer 1

16

As you've found out, you can do this via tweak-tool:

enter image description here

and indeed, the changes are now done in the dconf database so if you prefer doing it in terminal you need to toggle dynamic-workspaces to false and set the desired num-workspaces so either use the low-level dconf tool:

dconf write /org/gnome/mutter/dynamic-workspaces false
dconf write /org/gnome/desktop/wm/preferences/num-workspaces 4

or the high-level schema-aware gsettings tool:

gsettings set org.gnome.mutter dynamic-workspaces false
gsettings set org.gnome.desktop.wm.preferences num-workspaces 4

Altering those keys can be done also via dconf-editor.

1
  • That might work but in Debian-10 "Buster" the deconf edit does not include setting the number of workspaces. It used to be a Gnome "settings
    – Arv Evans
    Sep 13, 2019 at 16:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .