0

I can't get past the :

apt install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-4.18.0-kali2-amd64
E: Couldn't find any package by glob 'linux-headers-4.18.0-kali2-amd64'
E: Couldn't find any package by regex 'linux-headers-4.18.0-kali2-amd64'

I checked my sources.list which contains :

deb http://http.kali.org/kali kali-rolling main contrib non-free deb-src http://http.kali.org/kali kali-rolling main contrib non-free

uname -r returns :

4.18.0-kali2-amd64

And when I run

apt-cache search linux-image

I get :

linux-headers-4.18.0-kali3-amd64 - Header files for Linux 4.18.0-kali3-amd64 linux-headers-4.18.0-kali3-cloud-amd64 - Header files for Linux 4.18.0-kali3-cloud-amd64 linux-headers-4.18.0-kali3-rt-amd64 - Header files for Linux 4.18.0-kali3-rt-amd64 linux-image-4.18.0-kali3-amd64 - Linux 4.18 for 64-bit PCs linux-image-4.18.0-kali3-amd64-dbg - Debug symbols for linux-image-4.18.0-kali3-amd64 linux-image-4.18.0-kali3-cloud-amd64 - Linux 4.18 for x86-64 cloud linux-image-4.18.0-kali3-cloud-amd64-dbg - Debug symbols for linux-image-4.18.0-kali3-cloud-amd64 linux-image-4.18.0-kali3-rt-amd64 - Linux 4.18 for 64-bit PCs, PREEMPT_RT linux-image-4.18.0-kali3-rt-amd64-dbg - Debug symbols for linux-image-4.18.0-kali3-rt-amd64 linux-image-amd64 - Linux for 64-bit PCs (meta-package) linux-image-amd64-dbg - Debugging symbols for Linux amd64 configuration (meta-package) linux-image-cloud-amd64 - Linux for x86-64 cloud (meta-package) linux-image-cloud-amd64-dbg - Debugging symbols for Linux cloud-amd64 configuration (meta-package) linux-image-rt-amd64 - Linux for 64-bit PCs (meta-package), PREEMPT_RT linux-image-rt-amd64-dbg - Debugging symbols for Linux rt-amd64 configuration (meta-package) linux-image-4.18.0-kali2-amd64 - Linux 4.18 for 64-bit PCs

I'm running kali on an external SSD with live persistence.

I did update and upgrade.

marked as duplicate by GAD3R, Rui F Ribeiro, A.B, Stephen Harris, Thomas Dec 25 '18 at 15:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    No, I already tried the solutions offered there... – C. Auth Dec 24 '18 at 11:29
  • You should reread it. The values have changed but the problem is the same. You have to upgrade your kernel to -kali3, for which headers are available. – A.B Dec 24 '18 at 16:25
1

You need to upgrade your kernel package first, as you seem to have 4.18.0-kali2 installed but only 4.18.0-kali3 is available in the package repository at this time.

At the time you installed the kernel, the current version was 4.18.0-kali2. This is the risk of running a distribution that doesn't guarantee that versions remain available for a long period of time.

Note that even after installing the new kernel version, until you reboot into that kernel, $(uname -r) will still return the old version number.

  • Then you need to get an updated live image on your USB. – wurtel Dec 24 '18 at 14:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.