1

When I try to open a virtual machine, I get the error: "The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is permission problems with /dev/vboxdrv. Please reinstall virtualbox-dkms package and load the kernel module by executing 'modprobe vboxdrv' as root".

But when I execute 'modprobe vboxdrv', I get "could not insert 'vboxdrv':Required key not available."  I am using Ubuntu 18.04 LTS.

3

You probably have secure boot enabled in your bios. Check by running

 dmesg | grep -i secure

It is working as designed, stopping unsigned code being added to the kernel. Disable secure boot to allow the virtualbox kernel module to load.

  • It does say I have secure boot enabled. How do I disable it? – SourceEngine Dec 23 '18 at 1:40
  • nvm, I figured it out. – SourceEngine Dec 23 '18 at 2:10
  • 1
    @lukekong If this answer resolves your problem, remember to accept it by clicking the 'tick' mark next to the answer. – Haxiel Dec 23 '18 at 5:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.