0

I'm trying to install the newest versions of R and RStudio on Linux Mint version Sylvia, and it seems I also have some Ubuntu repositories on version Xenial. I have tried using the package manager years ago, but that gave me a very outdated version of R. I then tried to download the source files and run ./configure but it gives me the error configure: error: libcurl >= 7.22.0 library and headers are required with support for https.

I've seen mention of binaries, but when I look for the R binaries I get this page: (https://cran.r-project.org/bin/linux/ubuntu/xenial/) and I have no idea what to do with this, or even if I should be using xenial-cran3 instead. Looking up "how to install binaries" doesn't make it clear what I should be doing with this, if anything. Do I download each individual file on this page? Only some of them? Anyway, looking at other attempts ...

I made sure I have libcurl4-openssl-dev installed.

When I check the configure.log file it says

configure:40018: checking if libcurl supports https
configure:40042: gcc -o conftest -g -O2  -I/home/addem/anaconda3/include -I/usr/local/include  -L/usr/local/lib conftest.c -L/home/addem/anaconda3/lib -lcurl -lpcre -llzma -lbz2 -lz -lrt -ldl -lm  -licuuc -licui18n >&5
conftest.c: In function 'main':
conftest.c:267:5: warning: implicit declaration of function 'exit' [-Wimplicit-function-declaration]
     exit(found ? 0 : 1);
     ^
conftest.c:267:5: warning: incompatible implicit declaration of built-in function 'exit'
conftest.c:267:5: note: include '<stdlib.h>' or provide a declaration of 'exit'
/usr/bin/ld: warning: libssl.so.1.1, needed by /home/addem/anaconda3/lib/libcurl.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libcrypto.so.1.1, needed by /home/addem/anaconda3/lib/libcurl.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libcom_err.so.3, needed by /home/addem/anaconda3/lib/libcurl.so, not found (try using -rpath or -rpath-link)
/home/addem/anaconda3/lib/libcurl.so: undefined reference to `EVP_MD_CTX_free@OPENSSL_1_1_0'
/home/addem/anaconda3/lib/libcurl.so: undefined reference to `X509_EXTENSION_get_object@OPENSSL_1_1_0'
/home/addem/anaconda3/lib/libcurl.so: undefined reference to `SHA256_Final@OPENSSL_1_1_0'
/home/addem/anaconda3/lib/libcurl.so: undefined reference to `SSL_get_peer_cert_chain@OPENSSL_1_1_0'

And I'm not sure how to fix whatever is going on here.

At this point when I just try to install with sudo apt install base-r it tells me I have unmet dependencies, so I tried to install the listed dependencies, they had more dependencies. When I looked up how to install all dependencies, I ran sudo apt install -f and nothing got installed.

I've seen that this might be due to some conflicts with Anaconda in my path, but I use Anaconda often so I don't want to remove it from my path.

I've also tried updating all of this from within Anaconda, opening the navigator and updating its RStudio application. I was pretty sure this wouldn't work, and it didn't--it only gives me version 1 and says that it can't install a newer version. It doesn't give an explanation, but I'm guessing it's tied to the same reason the earlier attempts didn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.