0

I upgraded to Fedora 29 recently, and it keeps creating a fake network device wlp4s0 with a different fake macaddress every time:

> ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 192.168.0.1  netmask 255.255.255.0  broadcast 192.168.0.255
    ether <TRUE MAC ADDRESS OF MY CARD>  txqueuelen 1000 (Ethernet)
    RX packets 375891  bytes 523426707 (499.1 MiB)
    RX errors 0  dropped 3  overruns 0  frame 0
    TX packets 145987  bytes 12280970 (11.7 MiB)
    TX errors 1  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
    inet 127.0.0.1  netmask 255.0.0.0
    loop  txqueuelen 1000  (Local Loopback)
    RX packets 1167  bytes 190105 (185.6 KiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 1167  bytes 190105 (185.6 KiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp4s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
    ether 26:d2:a7:1b:7f:2b  txqueuelen 1000  (Ethernet)
    RX packets 0  bytes 0 (0.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 0  bytes 0 (0.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Even after issuing a ifconfig wlp4s0 down, after a minute or so it is created again. Commands ls /etc/sysconfig/network-scripts | grep wlp4s0 and grep wlp4s0 /etc/sysconfig/network-scripts/* give nothing.

I rename the network card with the following /etc/udev/rules.d/70-persistent-net.rules file:

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="78:2B:CB:ED:14:07", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

What should I do to prevent this from happening? Why is it creating a new network device?

  • docs.fedoraproject.org/en-US/Fedora/17/html/Wireless_Guide/… . I'd say it's probably this one that's changing the mac address (for privacy) and bringing it back despite your actions. You should handle it via network manager (eg nmcli). Also ifconfig is misleading you by not displaying down interfaces. try ip link instead (or for that matter iw wlp4s0 info or iw list) – A.B Dec 23 '18 at 9:39
  • @A.B: That page is for FC17, very old. But, anyway, the nmcli command does give some clues. It says: wlp4s0: disconnected "Qualcomm Atheros AR9485" wifi (ath9k), D6:C9:A7:4D:C0:24, hw, mtu 1500. So it is a wifi adapter. My desktop does not have any wifi adapters that I am aware of (it's actually very old). But it is wiredly connected to a router, that does have wifi. I disconnected the wired router, and still the adapter is recreated. – Luis A. Florit Dec 23 '18 at 12:50
0

wlp4s0 suggests that you have a wireless lan adapter on your system. The device is created for this adapter. On many laptops, there is a magic combination of fn-f11 (or f9, f10, or f12, depending on your specific brand of laptop) to disable the wifi. On other systems, that may be different.

When the wifi adapter is removed, the additional interface should also disappear.

  • My desktop does not have any wifi adapters that I am aware of (it's actually very old). The device is created even if I disconnect the network cables. The command nmcli gives: wlp4s0: disconnected "Qualcomm Atheros AR9485" wifi (ath9k), D6:C9:A7:4D:C0:24, hw, mtu 1500. The mac address varies each time the device is created, which suggests that the device is not an actual physical device...? – Luis A. Florit Dec 23 '18 at 12:52
  • Hm. Somehow, Fedora thinks that there is a Qualcomm Atheros AR9485 wifi adapter. It may be a good idea to look at the boot-logs and the dmesg. – Ljm Dullaart Dec 23 '18 at 13:10
  • Indeed. This is strange. dmesg gives me a line with AR9485: ieee80211 phy0: Atheros AR9485 Rev:1 mem=0xffffbea482580000, irq=19 and another line with Atheros: usb 3-13: Manufacturer: Atheros Communications. But I do not see any USB device plugged that could be giving this messages. Even unplugging everything the device keeps being created. – Luis A. Florit Dec 23 '18 at 17:56
  • 1
    Try to configure it and connect to a wifi network. Maybe your computer as more components than you thought... – Ljm Dullaart Dec 23 '18 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.