3

I am currently custumizing my .XCompose file in Fedora 29 Workstation (with the default GNOME 3, Wayland, etc). It seems that it does follow the rules I add to the ~/.XCompose file, but if I make changes to it then they are only noticed after I log out and log back in again. Is there something I can do to make the changes take effect immediately?

I tried running ibus restart on the terminal but it didn't seem to work. Actually, doing that broke the compose-key functionality completely and I had to restart the session again to fix it.

1

Under Fedora 30 (Gnome 3.30, X11), reloading Gnome Shell seems to work for me:

  1. Launch quick run with <Alt> + <F2>

  2. Type r then <Enter>

  3. Wait for the shell to reload

Somehow it even makes things work in some already running programs, which makes no sense to me...

  • 1
    Unfortunately this option is not available under wayland. In that case you must log out to reload the shell – hugomg May 2 at 19:14
0

About ~/.XCompose:

This file is read by libX11 whenever a new X program is started. So, your existing terminals won't be able to type these new characters, but any new terminals you launch will.

So, there's no way, unfortunately.

  • 1
    This isn't the same behavior I am encountering though. I have to restart the whole desktop session. Even relaunching programs is not enough. – hugomg Dec 22 '18 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.