0

When i boot my RHL vm into pxe mode by changing it to boot from the network, the connection times out

From the sequence i read of the PXE process described [here]https://docs.oracle.com/cd/E24628_01/em.121/e27046/appdx_pxeboot.htm#EMLCM121994 it seems the dhcp server is not replying to the request.

The DHCP server is on the same instance as the TFTP service and the DHCP service works to provide IPs to the VM's themselves. TFTP service wasnt running but i started it and got the same error.

Is there any other information i might provide to get an answer?

here is a screenshot of the first error and also the dhcp reference when i tried to use the dhcp command in the pxe menu: enter image description here

Update:

the dhcp server is assigning an IP now. I know this because the net0: IP is in the range of the DHCP service.

enter image description here So, the error is referencing nothing to boot but i have the pxelinux.0 file in the correct location and the DHCP tftp configuration is set to. Not sure what the problem is now.

Update 2 This continues to evolve as i apply different solutions. I found other users with the same error had applied the Oracle Virtualbox extension pack because this is required for the PXE usage. I think this resolved one issue and exposed another. After installing that extension pack to my Virtualbox install i now get a TFTP open Timeout:

enter image description here

i checked the status of the tftp server with systemctl status tftp.socket and it shows active.

Not sure where the disconnect is now.

4:

UPDATE 3: getting further down the road now. After opening UDP port 69 in the DHCP/TFTP server i now get to my PXE BOOT MENU but after i click on load from local disk I get FATAL :INT18: BOOT FAILURE

enter image description here

  • the issue should be searched on the dhcp server with logs and/or traces or the network between (including the hypervisor). So you should add information on this dhcp instance. Since the boot is stuck even before downloading a tftp boot, I don't even see why the question is tagged "linux", unless the dhcp instance is running linux. – A.B Dec 22 '18 at 3:02
  • @A.B i see an entry referencing office2 in the dhcp log on the dhcp server – colonuts panics Dec 27 '18 at 16:10
0

The DHCP server is responding, since the firmware gets an IP address. The next step is to fetch the boot file.

Set the TFTP server to log very verbosely, and see if it's getting a request in; if the request is coming in OK, note that the TFTP server might be restricted to some sub-tree.

For example, a RHEL TFTP server might be adding /tftpboot as a prefix to any requested filename by default. So if you configure the DHCP server to send a PXE boot filename as /pxelinux.0, the TFTP server will attempt to send /tftpboot/pxelinux.0 unless configured otherwise. This is good security, since TFTP has no real access control; although a TFTP server may only allow access to world-readable files, you still may not want to allow just anyone to download /etc/passwd or other files that might reveal security weaknesses.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.