0

I have a fresh install of Arch Linux that I am running on VirtualBox. However, I believe the problem is similar to the one in this thread.

My Terminal is not opening (doing the same thing described in that thread), and when I look at Settings - Region & Language, and see that the Language setting is set to Unspecified [ANSI_X3.4-1968 even though I set it to en_US.UTF-8 during the initial installation.

When I click on this and try to change it, the box just says No languages found. And I cannot open Terminal to try to edit my /etc/locale.gen file.

Thus, I would like to boot Arch Linux into the Terminal so that I can change it from there, but I'm unsure of how to do this. How can I fix this?

5
  • 2
    Switch to tty: wiki.archlinux.org/index.php/Keyboard_shortcuts; update /etc/locale.gen; reboot
    – bgregs
    Commented Dec 21, 2018 at 14:19
  • By "straight into Terminal", do you mean "boot to a virtual console" (the thing you switch to with ctrl-alt-f1), or do you still want the graphical environment, but with a GNOME terminal starting automatically?
    – JigglyNaga
    Commented Dec 21, 2018 at 14:30
  • @JigglyNaga I believe he can't open his terminal in the DE since he has an issue with his locale.gen (as per the answer he linked to). He just needs to switch to a tty and update it, and then he can boot back into his DE and load his terminal without issue. I don't think he wants a terminal starting automatically, but I could be mistaken
    – bgregs
    Commented Dec 21, 2018 at 14:35
  • @bgregs I can confirm that en_US.UTF-8 is uncommented, and I ran sudo locale-gen, and reboot the system, but when I go to the Settings within Gnome the Language still says Unspecified [ANSI_X3.4-1964 and won't allow me to change it.
    – NaN
    Commented Dec 21, 2018 at 14:42
  • Did you add LANG=en_US.UTF-8 to locale.conf? What does running locale -a give you?
    – bgregs
    Commented Dec 21, 2018 at 14:59

1 Answer 1

1

What I did was disable the display manager in the terminal by (assuming it is correct you're using Gnome):

systemctl disable gdm.service
reboot 

That did work for me, and if not, try also stopping the process as well

systemctl stop gdm.service

and reboot again. This would mean you still have Gnome running but you're just interacting with just command lines only and no desktop environment (you can always re-enable it by just swapping disable for enable and then reboot again).

(I only just installed Arch Linux yesterday so if I'm wrong, please do forgive me :P.)

I also just realised that you can't boot the terminal. I also ran into this problem. I believe I hadn't completed a step properly which was setting my language incorrectly (I don't know how I messed that up :) ) but using the desktop environment, I just went into the settings and went to region & language and changed my language to English, that then fixed my problem and was able to boot the terminal. There's a potential you may also have a problem with the format which is just underneath language, so try fixing that too.

Good Luck

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .