I have Win10 installed on a nvme drive. I have installed Fedora 29 on another ssd with LVM.

When grub boots, it shows Fedora & Windows 10 on the list, as it should.

But starting with Windows leads to a black screen with

...commands/search.c:296:no such device: 0897-5A52

and fails to load, goes back to grub menu. If I start on the Windows partition from BIOS UEFI menu, Windows starts ok.

The output from sudo blkid shows:

/dev/nvme0n1p2: UUID="0897-5A52" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="2a17028a-fbb0-40e8-940e-64c4d3082718"

The boot script for the Windows grub entry is:

insmod part_gpt
insmod fat
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root  0897-5A52
  search --no-floppy --fs-uuid --set=root 0897-5A52
chainloader /EFI/Microsoft/Boot/bootmgfw.efi

Everything looks fine to me, and I don't get why GRUB wouldn't find the "0897-5A52" UUID, because all indicates it exists and is the right handler.

Note: encryption is enabled on the Windows hdd, but I guess it does not encrypt the boot partition :)

  • The EFI system partition filesystem might have errors and need to be checked. – Michael Hampton Dec 28 '18 at 16:06
  • How would you do that? Solved it with below though – Mic Dec 28 '18 at 16:13

For the googlers out there.

I ended up replacing this code with a simple set=root /dev/nvme0n1p2 and it solved the issue. [But I ran into another one, which is another matter.]

I also saw somewhere insmod search_fs_uuid. Maybe adding that to my code would have made it work. Didn't try though.

Working config is thus:

insmod part_gpt
insmod fat
set root=/dev/nvme0n1p2
chainloader /EFI/Microsoft/Boot/bootmgfw.efi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.