3

This is with Ubuntu 18.04 on a Dell 7920. So the Dell power light goes on but I get nothing aside from the occasional flickering of the HD light, trying to boot when I put the 2080 in my box. (I have two actually and same thing with either one.) Everything boots fine when the RTX comes out. The monitor is plugged into an NVIDIA P2000 which came with the system. Same results before and after updating to most recent driver (415), which is explicitly supposed to support the 2080--though the problem happens so early on it seems unlikely to be a driver issue. I'm not even getting the Dell logo.

It's a fresh system, but legacy boot has been enabled and a few other changes have been made to ensure the HD can be encrypted. The computer booted with the 2080 before these changes were made, but there's probably no going back since the disk encryption is mandatory. (And the IT guy started his vacation today.) I've even tried different PCIe lanes, no change.

What can I try?

UPDATE: So on a hunch (anticipated by @SiXandSeven8ths) I took out the P2000 Quadro and things booted just fine, again with the 415.23 NVIDIA drivers. nvidia-smi works and everything appears in order. Is it really impossible to have both cards in the system at the same time (with nvidia drivers)? I'm happy to lose fancy graphics from the Quadro if need be, I just need it to run 2 monitors for mostly coding while the 2080s do ML. This post for example suggests that it is possible (see iamacow's response, 1st para.)--any suggestions how?

UPDATE 2: So it turned out to be surprisingly difficult to get things going even with a new low-end graphics card (GeForce 1050Ti). Two 2080Ti's did not work immediately; booting hung when the OS got to the point where it started the Gnome Display Manager. (Incidentally, for CUDA 10, needed to go with driver 410.48, manually installed from a .run file.) Reinstalling drivers did nothing, but everything 'just worked' when I switched from GDM to LightDM. To get the monitors to display from the new card, I had to get the GPU ID numbers from NVIDIA X Server Settings (different from what they are in nvidia-smi!!) and manually edit xorg.conf accordingly; doing it from the Settings GUI didn't seem to work, at least on the first try. But now, everything appears to be working as intended.

Last note: A fun fact about the 7920 is that despite packing a 1400W PSU it only has 3 PCIe 8-pin drops, while for 2 RTX's you need 4. A splitter solved this and since these cards max at about 280W I'm not too worried about overloading anything, though full disclosure the system has not been fully 'stress-tested' yet.

  • First off: can you confirm it not to be a hardware problem? Is UEFI/BIOS accessible? – Fiximan Dec 19 '18 at 21:48
  • 2
    Forgive me if I'm off here, but you're trying to plug a GeForce into a box with a Quadro still installed? What happens if you take the Quadro out? – SiXandSeven8ths Dec 19 '18 at 22:22
  • 1
    @SiXandSeven8ths If I do that, it works! This is a big surprise to me--the two cards conflict?! – Matt Phillips Dec 20 '18 at 12:25
  • 1
    @Fiximan Like I mentioned it's legacy boot which I thought might be a contributing issue (but is non-negotiable for the time being). Anyway yes see my edit, low-level hardware failures have been ruled out now. – Matt Phillips Dec 20 '18 at 12:43
1

I would suggest following the installation procedure for version 410 at http://www.linuxandubuntu.com/home/how-to-install-latest-nvidia-drivers-in-linux which entails

If you must have the Bleeding Edge drivers, see https://www.nvidia.com/download/driverResults.aspx/138279/en-us

  • 1
    I did this actually, except that even after adding the repo, the last install command failed with 'package not found'. However when I opened up Software & Updates, 410 and 415 were both options under 'Additional Drivers' so I chose the latter. Do you think 410 is worth trying? But see my question edit! – Matt Phillips Dec 20 '18 at 12:31
  • 1
    Done! .,.,.,.,., – Matt Phillips Dec 21 '18 at 13:05
1

Following @K7AAY's suggestion and making this an answer.

On a hunch (anticipated by @SiXandSeven8ths) I took out the P2000 Quadro and things booted just fine, again with the 415.23 NVIDIA drivers. nvidia-smi works and everything appears in order. I've since installed Cuda 10, CuDNN 7, PyTorch, and everything seems well. So the 'solution' here seems to be: you can't mix graphics card models in a single system, at least not without manual intervention of some kind. (E.g., editing an Xorg.conf file or something like that.). I'll need to replace the P2000 with a low-end GeForce model to achieve my goal of a lesser card for video display and two 'killer' cards for doing ML.

1

We ran into the same problem as you did and could only find this thread on the subject. I guess this message won't add to your particular solution as you already solved it, but it might help other people running into similar problems.

So, we bought a Netstor PCIe extension, which we wanted to use to upgrade our HP system (with one Quadro P4000) by adding two RTX 2080Ti cards in the external housing. After connecting everything we got a black screen, just like Matt Philips. In our case the presented solutions did not work.

We solved it by moving the Quadro P4000 card into the second PCIe slot and the connect the Netstor (with the two RTX2080Ti) to the first PCIe slot. The system starts up (very slowly) and the cards are recognized and functional.

Our guess is that the system starts looking for graphics cards in order. Anyway, it might be worth a try in changing the order of you GPUs.

Best,

New contributor
Smit is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.