0
  • We have beaglebone black based custom board.
  • We have cross compiled rfs in our build system,
  • We started adding user for custom applications,
  • As part of that we started updating file permissions, owner, group for file/folder.

We are using makedevs.c (similar to this one, though we are using timesys build system and not build root.)

Now at build time we need to do some verification with respect to file owner/group, When we list that file in the host PC it shows owner as root however when we extract it on the target it shows right owner/group id.

So my question is why it is not showing set UID/GID in host PC?
Is there anyway to see that information in host PC?

I tried using fakeroot and ls -l together but it didn't work, also I tried stat and fakeroot and stat together but it didn't work, either.

Any suggestion/pointers ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.