I have a scenario where I am trying to mount SAN storage to my linux machine. My environment details are-

  1. Oracle VM manager for VM creation
  2. Fiber Channel HP3PAR SAN storage attached as physical disk to my VM
  3. Oracle Linux version -OEL 7.4

Below steps I have been doing as earlier worked smoothly but not now-

  1. Login as root user on VM Running
  2. fdisk utility to check attached disks

    fdisk -l

    It shows 2 disks /dev/xvdb & /dev/xvdc where /dev/xvdc appeared after attaching the SAN storage to VM.

  3. Applying mount command to mount /dec/xvdc on location /u01/oracle/config where /u01/oracle/config is empty

    mount /dev/xvdc /u01/oracle/config

  4. After this the command screen cursor just blinks and nothing happens. Further I have checked whether the mount was successful, no it is not. Running the command 'df -h' and 'mount' doesn't shows the storage was mounted to requested location.

Storage attached but not able to mount

  • Syslog is where you should look at for error messages (like I/O timeouts). Also it looks as if you are running in a Xen Paravirtualized machine using disks imported from the Xen host (/dev/xvd*). If so, you should look at the Xen host... Anyway you should describe your scenario better. – U. Windl Dec 19 '18 at 11:24
  • mount also has a --verbose option that may be helpful. – Haxiel Dec 19 '18 at 17:15

Problem solved. The issue was associated with disk log corruption. So I tried to repair the disk using below steps-

xfs_repair /dev/xvdc 

a warning indicated as specified below

Phase 1 - find and verify superblock...

Phase 2 - using internal log

    - zero log...

ERROR: The filesystem has valuable metadata changes in a log which needs to be replayed. Mount the filesystem to replay the log, and unmount it before re-running xfs_repair. If you are unable to mount the filesystem, then use the -L option to destroy the log and attempt a repair. Note that destroying the log may cause corruption -- please attempt a mount of the filesystem before doing this.

So further, I proceeded with below steps-

xfs_repair -L /dev/xvdc 

mount -t xfs /dev/xvdc /u01/oracle

This successfully mount disk /dev/xvdc to location /u01/oracle.

NOTE : I have formatted the disk using XFS file system earlier.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.