0

I'm working through these instructions https://pycbc.org/pycbc/latest/html/install_lalsuite.html for installing pycbc which I need for my research, and I have some issues. Just under half way down that page, where it has

./00boot
./configure --prefix=${VIRTUAL_ENV}/opt/lalsuite --enable-swig-python --disable-lalstochastic --disable-lalxml --disable-lalinference --disable-laldetchar --disable-lalapps

I get these messages after running the ./configure line

checking whether PyArray_SetBaseObject is declared... yes

configure: error: SWIG version 2.0.12 or later is required 

SWIG support can be disabled by using the --disable-swig configure option

configure: error: ./configure failed for lal

There's plenty more above it if anyone wants the whole thing.

I tried following these instructions http://www.linuxfromscratch.org/blfs/view/7.5/general/swig.html and https://help.dreamhost.com/hc/en-us/articles/215489188-How-to-install-a-newer-version-of-SWIG but that hasn't helped.

I'm now out of ideas and worried that if I keep trying random things I'll make it worse. Yesterday I reinstalled Ubuntu onto this computer, so there shouldn't be too much mess about it.

Cheers!

** Edit

If I try just a simple

pip install lalsuite pycbc

as following these instructions https://pycbc.org/pycbc/latest/html/install.html I get a seg fault:

Collecting lalsuite
  Using cached https://files.pythonhosted.org/packages/c7/d3/d77caabf6f5e4000637624c9613a6ed21bf04bdb8478a215ac3600d4b13f/lalsuite-6.49-cp27-cp27mu-manylinux1_x86_64.whl
Collecting pycbc
Collecting ligo-segments (from lalsuite)
Collecting lscsoft-glue (from lalsuite)
Collecting matplotlib (from lalsuite)
  Using cached https://files.pythonhosted.org/packages/59/08/04933377dc4500e3698e93f9113dc3624874e0914f4c85767ecb5b389084/matplotlib-2.2.3-cp27-cp27mu-manylinux1_x86_64.whl
Collecting scipy (from lalsuite)
  Using cached https://files.pythonhosted.org/packages/45/d1/7c2b33a5daee3d67752d043fe7e1476c4465788b0b6e59367fd71fdf684a/scipy-1.2.0-cp27-cp27mu-manylinux1_x86_64.whl
Collecting python-dateutil (from lalsuite)
  Using cached https://files.pythonhosted.org/packages/74/68/d87d9b36af36f44254a8d512cbfc48369103a3b9e474be9bdfe536abfc45/python_dateutil-2.7.5-py2.py3-none-any.whl
Collecting numpy>=1.7 (from lalsuite)
  Using cached https://files.pythonhosted.org/packages/de/37/fe7db552f4507f379d81dcb78e58e05030a8941757b1f664517d581b5553/numpy-1.15.4-cp27-cp27mu-manylinux1_x86_64.whl
Collecting beautifulsoup4>=4.6.0 (from pycbc)
  Using cached https://files.pythonhosted.org/packages/f8/c7/741c97d7366f4779ca73d244904978b43a81fd37d85fcf05ad19d472c1ce/beautifulsoup4-4.6.3-py2-none-any.whl
Collecting cython (from pycbc)
  Using cached https://files.pythonhosted.org/packages/eb/b0/0069db01146b4810cbe2d7045ebbc80baca5470ee4b51b1e991eb90d8f07/Cython-0.29.2-cp27-cp27mu-manylinux1_x86_64.whl
Collecting jinja2 (from pycbc)
  Using cached https://files.pythonhosted.org/packages/7f/ff/ae64bacdfc95f27a016a7bed8e8686763ba4d277a78ca76f32659220a731/Jinja2-2.10-py2.py3-none-any.whl
Collecting emcee==2.2.1 (from pycbc)
Collecting requests>=1.2.1 (from pycbc)
  Using cached https://files.pythonhosted.org/packages/7d/e3/20f3d364d6c8e5d2353c72a67778eb189176f08e873c9900e10c0287b84b/requests-2.21.0-py2.py3-none-any.whl
Collecting six>=1.10.0 (from pycbc)
  Using cached https://files.pythonhosted.org/packages/73/fb/00a976f728d0d1fecfe898238ce23f502a721c0ac0ecfedb80e0d88c64e9/six-1.12.0-py2.py3-none-any.whl
Collecting pillow (from pycbc)
  Using cached https://files.pythonhosted.org/packages/9a/f6/3b3c82c5c75cae471e02fb584136168d732e17ae9db2d21c5dc82f9790f8/Pillow-5.3.0-cp27-cp27mu-manylinux1_x86_64.whl
Collecting mpld3>=0.3 (from pycbc)
Collecting kombine>=0.8.2 (from pycbc)
  Using cached https://files.pythonhosted.org/packages/ce/70/d7eff8255247dd56b89f6547067ad418c10f71e796968f6208adbb68e032/kombine-0.8.3-py2.py3-none-any.whl
Collecting weave>=0.16.0 (from pycbc)
Collecting h5py>=2.5 (from pycbc)
  Downloading https://files.pythonhosted.org/packages/53/08/27e4e9a369321862ffdce80ff1770553e9daec65d98befb2e14e7478b698/h5py-2.9.0-cp27-cp27mu-manylinux1_x86_64.whl (2.8MB)
    100% |████████████████████████████████| 2.8MB 453kB/s 
Collecting Mako>=1.0.1 (from pycbc)
Collecting decorator>=3.4.2 (from pycbc)
  Using cached https://files.pythonhosted.org/packages/bc/bb/a24838832ba35baf52f32ab1a49b906b5f82fb7c76b2f6a7e35e140bac30/decorator-4.3.0-py2.py3-none-any.whl
Collecting astropy<3.0.0,>=2.0.3 (from pycbc)
Collecting ligo-common (from ligo-segments->lalsuite)
  Using cached https://files.pythonhosted.org/packages/a6/9c/1fbe176feea9abad5c0f3fa090dcffccf44bbcba0f0c754b03d8fea1a36e/ligo_common-1.0.3-py2.py3-none-any.whl
Collecting pyOpenSSL (from lscsoft-glue->lalsuite)
  Using cached https://files.pythonhosted.org/packages/96/af/9d29e6bd40823061aea2e0574ccb2fcf72bfd6130ce53d32773ec375458c/pyOpenSSL-18.0.0-py2.py3-none-any.whl
Collecting pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 (from matplotlib->lalsuite)
  Using cached https://files.pythonhosted.org/packages/71/e8/6777f6624681c8b9701a8a0a5654f3eb56919a01a78e12bf3c73f5a3c714/pyparsing-2.3.0-py2.py3-none-any.whl
Collecting backports.functools-lru-cache (from matplotlib->lalsuite)
  Using cached https://files.pythonhosted.org/packages/03/8e/2424c0e65c4a066e28f539364deee49b6451f8fcd4f718fefa50cc3dcf48/backports.functools_lru_cache-1.5-py2.py3-none-any.whl
Collecting subprocess32 (from matplotlib->lalsuite)
Collecting pytz (from matplotlib->lalsuite)
  Using cached https://files.pythonhosted.org/packages/f8/0e/2365ddc010afb3d79147f1dd544e5ee24bf4ece58ab99b16fbb465ce6dc0/pytz-2018.7-py2.py3-none-any.whl
Collecting kiwisolver>=1.0.1 (from matplotlib->lalsuite)
  Using cached https://files.pythonhosted.org/packages/3a/62/a8c9bef3059d55ab38e41fe9cba4fad773bfc04e47290bab84db1c18262e/kiwisolver-1.0.1-cp27-cp27mu-manylinux1_x86_64.whl
Collecting cycler>=0.10 (from matplotlib->lalsuite)
  Using cached https://files.pythonhosted.org/packages/f7/d2/e07d3ebb2bd7af696440ce7e754c59dd546ffe1bbe732c8ab68b9c834e61/cycler-0.10.0-py2.py3-none-any.whl
Collecting MarkupSafe>=0.23 (from jinja2->pycbc)
  Using cached https://files.pythonhosted.org/packages/bc/3a/6bfd7b4b202fa33bdda8e4e3d3acc719f381fd730f9a0e7c5f34e845bd4d/MarkupSafe-1.1.0-cp27-cp27mu-manylinux1_x86_64.whl
Collecting chardet<3.1.0,>=3.0.2 (from requests>=1.2.1->pycbc)
  Using cached https://files.pythonhosted.org/packages/bc/a9/01ffebfb562e4274b6487b4bb1ddec7ca55ec7510b22e4c51f14098443b8/chardet-3.0.4-py2.py3-none-any.whl
Collecting idna<2.9,>=2.5 (from requests>=1.2.1->pycbc)
  Using cached https://files.pythonhosted.org/packages/14/2c/cd551d81dbe15200be1cf41cd03869a46fe7226e7450af7a6545bfc474c9/idna-2.8-py2.py3-none-any.whl
Collecting certifi>=2017.4.17 (from requests>=1.2.1->pycbc)
  Using cached https://files.pythonhosted.org/packages/9f/e0/accfc1b56b57e9750eba272e24c4dddeac86852c2bebd1236674d7887e8a/certifi-2018.11.29-py2.py3-none-any.whl
Collecting urllib3<1.25,>=1.21.1 (from requests>=1.2.1->pycbc)
  Using cached https://files.pythonhosted.org/packages/62/00/ee1d7de624db8ba7090d1226aebefab96a2c71cd5cfa7629d6ad3f61b79e/urllib3-1.24.1-py2.py3-none-any.whl
Collecting pytest<3.7,>=2.8 (from astropy<3.0.0,>=2.0.3->pycbc)
  Using cached https://files.pythonhosted.org/packages/d8/e9/73246a565c34c5f203dd78bc2382e0e93aa7a249cdaeba709099eb1bc701/pytest-3.6.4-py2.py3-none-any.whl
Collecting cryptography>=2.2.1 (from pyOpenSSL->lscsoft-glue->lalsuite)
  Using cached https://files.pythonhosted.org/packages/7f/ba/383b51cc26e3141c689ce988814385c7659f5ba01c4b5f2de38233010b5f/cryptography-2.4.2-cp27-cp27mu-manylinux1_x86_64.whl
Collecting setuptools (from kiwisolver>=1.0.1->matplotlib->lalsuite)
  Using cached https://files.pythonhosted.org/packages/37/06/754589caf971b0d2d48f151c2586f62902d93dc908e2fd9b9b9f6aa3c9dd/setuptools-40.6.3-py2.py3-none-any.whl
Collecting pluggy<0.8,>=0.5 (from pytest<3.7,>=2.8->astropy<3.0.0,>=2.0.3->pycbc)
  Using cached https://files.pythonhosted.org/packages/f5/f1/5a93c118663896d83f7bcbfb7f657ce1d0c0d617e6b4a443a53abcc658ca/pluggy-0.7.1-py2.py3-none-any.whl
Collecting atomicwrites>=1.0 (from pytest<3.7,>=2.8->astropy<3.0.0,>=2.0.3->pycbc)
  Using cached https://files.pythonhosted.org/packages/3a/9a/9d878f8d885706e2530402de6417141129a943802c084238914fa6798d97/atomicwrites-1.2.1-py2.py3-none-any.whl
Collecting py>=1.5.0 (from pytest<3.7,>=2.8->astropy<3.0.0,>=2.0.3->pycbc)
  Using cached https://files.pythonhosted.org/packages/3e/c7/3da685ef117d42ac8d71af525208759742dd235f8094221fdaafcd3dba8f/py-1.7.0-py2.py3-none-any.whl
Collecting funcsigs; python_version < "3.0" (from pytest<3.7,>=2.8->astropy<3.0.0,>=2.0.3->pycbc)
  Using cached https://files.pythonhosted.org/packages/69/cb/f5be453359271714c01b9bd06126eaf2e368f1fddfff30818754b5ac2328/funcsigs-1.0.2-py2.py3-none-any.whl
Collecting more-itertools>=4.0.0 (from pytest<3.7,>=2.8->astropy<3.0.0,>=2.0.3->pycbc)
  Using cached https://files.pythonhosted.org/packages/fb/d3/77f337876600747ae307ea775ff264c5304a691941cd347382c7932c60ad/more_itertools-4.3.0-py2-none-any.whl
Collecting attrs>=17.4.0 (from pytest<3.7,>=2.8->astropy<3.0.0,>=2.0.3->pycbc)
  Using cached https://files.pythonhosted.org/packages/3a/e1/5f9023cc983f1a628a8c2fd051ad19e76ff7b142a0faf329336f9a62a514/attrs-18.2.0-py2.py3-none-any.whl
Collecting enum34; python_version < "3" (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
  Using cached https://files.pythonhosted.org/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
Collecting cffi!=1.11.3,>=1.7 (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
  Using cached https://files.pythonhosted.org/packages/14/dd/3e7a1e1280e7d767bd3fa15791759c91ec19058ebe31217fe66f3e9a8c49/cffi-1.11.5-cp27-cp27mu-manylinux1_x86_64.whl
Collecting asn1crypto>=0.21.0 (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
  Using cached https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
Collecting ipaddress; python_version < "3" (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
  Using cached https://files.pythonhosted.org/packages/fc/d0/7fc3a811e011d4b388be48a0e381db8d990042df54aa4ef4599a31d39853/ipaddress-1.0.22-py2.py3-none-any.whl
Collecting pycparser (from cffi!=1.11.3,>=1.7->cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
Installing collected packages: ligo-common, six, ligo-segments, enum34, pycparser, cffi, asn1crypto,    enCollecting lalsuite
      Using cached https://files.pythonhosted.org/packages/c7/d3/d77caabf6f5e4000637624c9613a6ed21bf04bdb8478a215ac3600d4b13f/lalsuite-6.49-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting ligo-segments (from lalsuite)
    Collecting lscsoft-glue (from lalsuite)
    Collecting matplotlib (from lalsuite)
      Using cached https://files.pythonhosted.org/packages/59/08/04933377dc4500e3698e93f9113dc3624874e0914f4c85767ecb5b389084/matplotlib-2.2.3-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting scipy (from lalsuite)
      Using cached https://files.pythonhosted.org/packages/45/d1/7c2b33a5daee3d67752d043fe7e1476c4465788b0b6e59367fd71fdf684a/scipy-1.2.0-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting python-dateutil (from lalsuite)
      Using cached https://files.pythonhosted.org/packages/74/68/d87d9b36af36f44254a8d512cbfc48369103a3b9e474be9bdfe536abfc45/python_dateutil-2.7.5-py2.py3-none-any.whl
    Collecting numpy>=1.7 (from lalsuite)
      Using cached https://files.pythonhosted.org/packages/de/37/fe7db552f4507f379d81dcb78e58e05030a8941757b1f664517d581b5553/numpy-1.15.4-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting ligo-common (from ligo-segments->lalsuite)
      Using cached https://files.pythonhosted.org/packages/a6/9c/1fbe176feea9abad5c0f3fa090dcffccf44bbcba0f0c754b03d8fea1a36e/ligo_common-1.0.3-py2.py3-none-any.whl
    Collecting six (from ligo-segments->lalsuite)
      Using cached https://files.pythonhosted.org/packages/73/fb/00a976f728d0d1fecfe898238ce23f502a721c0ac0ecfedb80e0d88c64e9/six-1.12.0-py2.py3-none-any.whl
    Collecting pyOpenSSL (from lscsoft-glue->lalsuite)
      Using cached https://files.pythonhosted.org/packages/96/af/9d29e6bd40823061aea2e0574ccb2fcf72bfd6130ce53d32773ec375458c/pyOpenSSL-18.0.0-py2.py3-none-any.whl
    Collecting pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 (from matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/71/e8/6777f6624681c8b9701a8a0a5654f3eb56919a01a78e12bf3c73f5a3c714/pyparsing-2.3.0-py2.py3-none-any.whl
    Collecting backports.functools-lru-cache (from matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/03/8e/2424c0e65c4a066e28f539364deee49b6451f8fcd4f718fefa50cc3dcf48/backports.functools_lru_cache-1.5-py2.py3-none-any.whl
    Collecting subprocess32 (from matplotlib->lalsuite)
    Collecting pytz (from matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/f8/0e/2365ddc010afb3d79147f1dd544e5ee24bf4ece58ab99b16fbb465ce6dc0/pytz-2018.7-py2.py3-none-any.whl
    Collecting kiwisolver>=1.0.1 (from matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/3a/62/a8c9bef3059d55ab38e41fe9cba4fad773bfc04e47290bab84db1c18262e/kiwisolver-1.0.1-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting cycler>=0.10 (from matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/f7/d2/e07d3ebb2bd7af696440ce7e754c59dd546ffe1bbe732c8ab68b9c834e61/cycler-0.10.0-py2.py3-none-any.whl
    Collecting cryptography>=2.2.1 (from pyOpenSSL->lscsoft-glue->lalsuite)
      Using cached https://files.pythonhosted.org/packages/7f/ba/383b51cc26e3141c689ce988814385c7659f5ba01c4b5f2de38233010b5f/cryptography-2.4.2-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting setuptools (from kiwisolver>=1.0.1->matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/37/06/754589caf971b0d2d48f151c2586f62902d93dc908e2fd9b9b9f6aa3c9dd/setuptools-40.6.3-py2.py3-none-any.whl
    Collecting enum34; python_version < "3" (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
      Using cached https://files.pythonhosted.org/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl    enCollecting lalsuite
      Using cached https://files.pythonhosted.org/packages/c7/d3/d77caabf6f5e4000637624c9613a6ed21bf04bdb8478a215ac3600d4b13f/lalsuite-6.49-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting ligo-segments (from lalsuite)
    Collecting lscsoft-glue (from lalsuite)
    Collecting matplotlib (from lalsuite)
      Using cached https://files.pythonhosted.org/packages/59/08/04933377dc4500e3698e93f9113dc3624874e0914f4c85767ecb5b389084/matplotlib-2.2.3-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting scipy (from lalsuite)
      Using cached https://files.pythonhosted.org/packages/45/d1/7c2b33a5daee3d67752d043fe7e1476c4465788b0b6e59367fd71fdf684a/scipy-1.2.0-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting python-dateutil (from lalsuite)
      Using cached https://files.pythonhosted.org/packages/74/68/d87d9b36af36f44254a8d512cbfc48369103a3b9e474be9bdfe536abfc45/python_dateutil-2.7.5-py2.py3-none-any.whl
    Collecting numpy>=1.7 (from lalsuite)
      Using cached https://files.pythonhosted.org/packages/de/37/fe7db552f4507f379d81dcb78e58e05030a8941757b1f664517d581b5553/numpy-1.15.4-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting ligo-common (from ligo-segments->lalsuite)
      Using cached https://files.pythonhosted.org/packages/a6/9c/1fbe176feea9abad5c0f3fa090dcffccf44bbcba0f0c754b03d8fea1a36e/ligo_common-1.0.3-py2.py3-none-any.whl
    Collecting six (from ligo-segments->lalsuite)
      Using cached https://files.pythonhosted.org/packages/73/fb/00a976f728d0d1fecfe898238ce23f502a721c0ac0ecfedb80e0d88c64e9/six-1.12.0-py2.py3-none-any.whl
    Collecting pyOpenSSL (from lscsoft-glue->lalsuite)
      Using cached https://files.pythonhosted.org/packages/96/af/9d29e6bd40823061aea2e0574ccb2fcf72bfd6130ce53d32773ec375458c/pyOpenSSL-18.0.0-py2.py3-none-any.whl
    Collecting pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 (from matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/71/e8/6777f6624681c8b9701a8a0a5654f3eb56919a01a78e12bf3c73f5a3c714/pyparsing-2.3.0-py2.py3-none-any.whl
    Collecting backports.functools-lru-cache (from matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/03/8e/2424c0e65c4a066e28f539364deee49b6451f8fcd4f718fefa50cc3dcf48/backports.functools_lru_cache-1.5-py2.py3-none-any.whl
    Collecting subprocess32 (from matplotlib->lalsuite)
    Collecting pytz (from matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/f8/0e/2365ddc010afb3d79147f1dd544e5ee24bf4ece58ab99b16fbb465ce6dc0/pytz-2018.7-py2.py3-none-any.whl
    Collecting kiwisolver>=1.0.1 (from matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/3a/62/a8c9bef3059d55ab38e41fe9cba4fad773bfc04e47290bab84db1c18262e/kiwisolver-1.0.1-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting cycler>=0.10 (from matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/f7/d2/e07d3ebb2bd7af696440ce7e754c59dd546ffe1bbe732c8ab68b9c834e61/cycler-0.10.0-py2.py3-none-any.whl
    Collecting cryptography>=2.2.1 (from pyOpenSSL->lscsoft-glue->lalsuite)
      Using cached https://files.pythonhosted.org/packages/7f/ba/383b51cc26e3141c689ce988814385c7659f5ba01c4b5f2de38233010b5f/cryptography-2.4.2-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting setuptools (from kiwisolver>=1.0.1->matplotlib->lalsuite)
      Using cached https://files.pythonhosted.org/packages/37/06/754589caf971b0d2d48f151c2586f62902d93dc908e2fd9b9b9f6aa3c9dd/setuptools-40.6.3-py2.py3-none-any.whl
    Collecting enum34; python_version < "3" (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
      Using cached https://files.pythonhosted.org/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
    Collecting cffi!=1.11.3,>=1.7 (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
      Using cached https://files.pythonhosted.org/packages/14/dd/3e7a1e1280e7d767bd3fa15791759c91ec19058ebe31217fe66f3e9a8c49/cffi-1.11.5-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting asn1crypto>=0.21.0 (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
      Using cached https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
    Collecting idna>=2.1 (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
      Using cached https://files.pythonhosted.org/packages/14/2c/cd551d81dbe15200be1cf41cd03869a46fe7226e7450af7a6545bfc474c9/idna-2.8-py2.py3-none-any.whl
    Collecting ipaddress; python_version < "3" (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
      Using cached https://files.pythonhosted.org/packages/fc/d0/7fc3a811e011d4b388be48a0e381db8d990042df54aa4ef4599a31d39853/ipaddress-1.0.22-py2.py3-none-any.whl
    Collecting pycparser (from cffi!=1.11.3,>=1.7->cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
    Installing collected packages: ligo-common, six, ligo-segments, enum34, pycparser, cffi, asn1crypto, idna, ipaddress, cryptography, pyOpenSSL, numpy, lscsoft-glue, pyparsing, backports.functools-lru-cache, subprocess32, python-dateutil, pytz, setuptools, kiwisolver, cycler, matplotlib, scipy, lalsuite
    Segmentation fault (core dumped)
Collecting cffi!=1.11.3,>=1.7 (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
  Using cached https://files.pythonhosted.org/packages/14/dd/3e7a1e1280e7d767bd3fa15791759c91ec19058ebe31217fe66f3e9a8c49/cffi-1.11.5-cp27-cp27mu-manylinux1_x86_64.whl
Collecting asn1crypto>=0.21.0 (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
  Using cached https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
Collecting idna>=2.1 (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
  Using cached https://files.pythonhosted.org/packages/14/2c/cd551d81dbe15200be1cf41cd03869a46fe7226e7450af7a6545bfc474c9/idna-2.8-py2.py3-none-any.whl
Collecting ipaddress; python_version < "3" (from cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
  Using cached https://files.pythonhosted.org/packages/fc/d0/7fc3a811e011d4b388be48a0e381db8d990042df54aa4ef4599a31d39853/ipaddress-1.0.22-py2.py3-none-any.whl
Collecting pycparser (from cffi!=1.11.3,>=1.7->cryptography>=2.2.1->pyOpenSSL->lscsoft-glue->lalsuite)
Installing collected packages: ligo-common, six, ligo-segments, enum34, pycparser, cffi, asn1crypto, idna, ipaddress, cryptography, pyOpenSSL, numpy, lscsoft-glue, pyparsing, backports.functools-lru-cache, subprocess32, python-dateutil, pytz, setuptools, kiwisolver, cycler, matplotlib, scipy, lalsuite
Segmentation fault (core dumped) idna, ipaddress, cryptography, pyOpenSSL, numpy, lscsoft-glue, pyparsing, backports.functools-lru-cache, subprocess32, python-dateutil, pytz, setuptools, kiwisolver, cycler, matplotlib, scipy, lalsuite, beautifulsoup4, cython, MarkupSafe, jinja2, emcee, chardet, certifi, urllib3, requests, pillow, mpld3, kombine, weave, h5py, Mako, decorator, pluggy, atomicwrites, py, funcsigs, more-itertools, attrs, pytest, astropy, pycbc

Segmentation fault (core dumped)

0

If you just want to install lalsuite and not develop it, have you considered installing from pip as pip install lalsuite?

If you do want to build from source and want to install swig, it might be easier to use your package manager since swig3 is available.

https://packages.ubuntu.com/cosmic/swig

Something like apt-get install swig3.

  • That was the first thing I tried.. I don't have the computer with me right now though so I can't say why that failed – user1153070 Dec 20 '18 at 13:54
  • And I'm not interested in developing anything, I just want to use it. – user1153070 Dec 20 '18 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.