1

Background

I'm using Ubuntu 18.04 server (on a laptop, for development) and am trying to get my wifi configured to work with an WPA-EAP network.

I've got netplan to work with an an open network, even with a password protected network, but haven't been able to get it to work with WPA-EAP where both an identity and password are required.

Attempted Configuration

I've tried this in my /etc/netplan/config.yaml file:

network:
    wifis:
      wlp1s0:
        dhcp4: yes
        access-points:
          "My-Enterprise-Network":
            auth:
              key-management: eap
              identity: johndoe1
              password: pass1234

But when I run netplan apply I get:

Error in network definition /etc/netplan/config.yaml: unknown key auth

From the Documentation

From the online netplan documentation:

 The ``auth`` block supports the following properties:

 ``key-management`` (scalar)
 :    The supported key management modes are ``none`` (no key management);
      ``psk`` (WPA with pre-shared key, common for home wifi); ``eap`` (WPA
      with EAP, common for enterprise wifi); and ``802.1x`` (used primarily
      for wired Ethernet connections).

 ``password`` (scalar)
 :    The password string for EAP, or the pre-shared key for WPA-PSK.

 The following properties can be used if ``key-management`` is ``eap``
 or ``802.1x``:

 ``method`` (scalar)
 :    The EAP method to use. The supported EAP methods are ``tls`` (TLS),
      ``peap`` (Protected EAP), and ``ttls`` (Tunneled TLS).

 ``identity`` (scalar)
 :    The identity to use for EAP.

From man netplan

access-points (mapping)
      This  provides  pre-configured connections to NetworkManager.  
      Note that users can of course select other access points/SSIDs.  
      The keys of the mapping are the SSIDs, and the values are mappings
      with the following supported properties:

      password (scalar)
             Enable WPA2 authentication and set the passphrase for it.  
             If not given, the network is assumed to be open. 
             **Other authentication  modes  are not currently supported.**

Note the last line: Other authentication modes are not currently supported.

Questions

  1. What's the right way to use netplan with WPA-EAP?
  2. Does Ubuntu 18.04 ship with an outdated version of netplan? ( netplan --version is not supported ) Hence perhaps why the online documentation has options that the man version does not?
  3. If so, can I upgrade netplan to a more cutting edge release?
  4. Or does netplan need to be used with something like a wpa_supplicant.conf to specify additional parameters?
  • Did you try leaving out the line auth: ... and simply jump right to the key-management: line? – RubberStamp Dec 18 '18 at 20:36
  • @RubberStamp - I did try that. It says Error in network definition: unknown key key-management – cwd Dec 19 '18 at 19:46
  • The problem is with the form of the definition... the unknown key is because the yaml file is incorrect... it doesn't mean that the authentication method isn't working, because netplan didn't get that far... Make sure that there are no tabs in the file, only spaces. And then create a very basic netplan configuration for a regular network port to ensure you have the proper format, spacing, and so forth. – RubberStamp Dec 19 '18 at 20:12
0

You should upgrade your netplan.io package to make this work.

The ubuntu repository on http://nl.archive.ubuntu.com/ubuntu/pool/main/n/netplan.io/ contains a version like netplan.io_0.96-0ubuntu0.18.04.4_amd64.deb, or whatever architecture you might have. The default version is too old.

I installed this on my ubuntu 18.04 LTS with:

dpkg -i netplan.io_0.96-0ubuntu0.18.04.4_amd64.deb

and it installs without further dependencies, so it is a drop-in replacement.

Your "netplan generate" will not suffer from unknown 'auth key' anymore. The following works for me to access public Ziggo hot spots:

wifis: wlp1s0: dhcp4: true access-points: "<SSID>": auth: key-management: eap password: <secret> method: peap identity: <hiddenid> ca-certificate: /etc/WIFI.pem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.