1

There is a VCS repo that has 2 branches - master and release. There are also 2 Debian packages that are built from these branches - let's say foo for the release branch and foo-master for the master branch. In the Provides section they both have just foo

Package foo is of version 1.5, the other one is of version 1.6. There is also another package, let's say bar, that depends on the package foo.

The problem is how to install the package bar with the latest version of the package foo. When I specify foo (<< 1.7) as a dependency of bar, it still installs foo of version 1.5. But if I rewrite it as foo (>= 1.6) it installs the latest version of foo.

Why does this happen?

  • Are you running apt-get install -t [reponame] foo=foo-1.6 to install foo? – kemotep Dec 18 '18 at 15:24
  • @kemotep I'm trying to install this package indirectly, as a dependency of the package bar – Henry Barker Dec 19 '18 at 9:09
  • @HenryBarker did rebuilding the package help solve your issue? This is very vague, using foo and bar, you may get better answers if you specify the exact packages and repository you are having issues with. – kemotep Jan 2 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.