3

Problem

I use guake to hide away my terminals when I'm not using them. When I am, they fullscreen an entire monitor. If I run a command requiring an unlock of a private key, Seahorse opens a modal dialog asking for the passphrase. Unfortunately, the dialog is drawn behind guake. Perhaps I can simply blindly unlock the key, but the combination of invisibility and having mashed some keys before realising what's happened means this hasn't worked for me so far, and possibly just doesn't work at all. Certainly hammering esc and other "get me out of here" keys doesn't help. In case it needs mentioning, the shortcut to raise/hide guake obviously does not work either.

I have several different keys with passphrases. Most of these keys are added to my ssh agent, but some are rarely used and I don't want to unlock every one of them on boot. It's these rarely used keys that cause the above problem.

Terrible Solution

So, I do have a solution, but it feels horribly hacky. This relies on having xdotool installed. Ctrl+Alt+F1 to hop to another VT and run the following:

export DISPLAY=0:0
xdotool search 'guake.py' | while read W; do xdotool windowminimize "$W"; done

Now Ctrl+Alt+F7 back to the desktop environment, and guake has disappeared. I could simply switch to another VT and kill guake, but it's frustrating to reopen a dozen SSH sessions to various machines when I do.

Question

I'm looking for better ways to escape from the uninteractable modal dialog. Secret key combinations, ways to configure Seahorse to never ask me anything ever, WM tweaks to have it 'on top, no, really', etc. Any advice about how people manage their agent/key setups would peripherally be appreciated too.

  • Not really an answer, but I just run ssh-add from the command line, before the first time I use a new key. Sometimes I forget, the ssh prompt pops up, I ctrl-C and then add the key. Works for me! – ire_and_curses Sep 24 '12 at 1:23
  • I guess this highlights some poor question-asking on my behalf. Sometimes I get Seahorse asking me for the passphrase, and sometimes I get the ^C-escapable prompt you mention. There doesn't seem to be a correlation between the keys that Seahorse wants to handle and which keys are listed within Seahorse. – Ben Graham Sep 24 '12 at 1:25
  • 1
    Is Guake claiming the top most window? If no, Alt+Tab should work. Otherwise my first idea was to get a another window manager and redefine the behaviors (modal dialogs always on top f.e.). – Bobby Sep 24 '12 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.