0

I want to communicate with my girlfriend through the write command. She's on a mac, I am on a debian laptop. I did the next steps:

  1. adduser haly
  2. apt-get install openssh-server
  3. systemctl start ssh

Then she logins with ssh haly@my ip address (we are both connected to the same wifi) with the given password. In our terminals we both do mesg y and I do write haly. She can see everything I write, but I cannot see anything she writes. What is wrong?

Thanks

[Editing to have a more complete question]

This is me:

murphy@eva02:~$ who
murphy   tty2         2018-12-17 22:58 (:0)
haly     pts/1        2018-12-17 23:25 (192.168.0.9)
murphy@eva02:~$ mesg y
murphy@eva02:~$ write haly pts/1
las rosas son rojas, el cielo es azul ...

She receives the last line in her terminal (after logging into eva02 and doing mesg y). But If she tries write murphy tty2 the write program seems to work in her terminal, but I see nothing in mine.

3

Nothing is wrong; write is unidirectional:

Any further lines you enter will be copied to the specified user's terminal. If the other user wants to reply, they must run write as well.

... so she must write your-username in order to write back to you.

You may be thinking of the more-interactive talk utility; on Debian, apt install ytalk will get you started.

  • Yeah, the man doc on write says that "If the other user wants to reply, they must run write as well." She does but I see nothing on my end. – murpholinox Dec 18 '18 at 5:39
  • With talk I cannot communicate with her (the program stays forever on "Checking on invitation on caller's machine") – murpholinox Dec 18 '18 at 5:58
  • Yes, write is unidirectional, but if she writes to me I receive nothing. talk seems better but did not work... ytalk on the other hand worked pretty well. Thanks – murpholinox Dec 18 '18 at 6:39
  • After she does write murphy, does she type another line (and hit Enter)? – Jeff Schaller Dec 18 '18 at 14:26
  • Yeah, we tried it...but nothing. Obviously I did mesg y as well. There has to be something wrong with write and talk, because there was no problem at all with ytalk. – murpholinox Dec 20 '18 at 4:11
0

Try having her add your device name. You can use who, w or finger to get this information. Usage: write username devicename , see if that helps...

  • Not working. write haly pts/0 gives the same behavior: she receives my messages, I do not receive anything. – murpholinox Dec 17 '18 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.