2

I have just bought an Asus Zenbook UX433FA, on which I want to install Deepin 15.8 as my only OS. I have followed the installation guide on the Deepin website, therefore creating a bootable USB device with a Deepin iso (tried 15.8, 15.7, and 15.4) from which I would later attempt booting up.

I also disabled SecureBoot and FastStartup in the BIOS setup.

However, when booting from the USB device, I get presented a black screen with a non-blinking white dash in the top-left corner instead of being shown the Deepin Installer---no matter what the Deepin iso version is.

I was nonetheless able to install Ubuntu 18.04 using the same method without any issue whatsoever, so this should be Deepin related.

Note that I tried by bootable USB drive on another laptop of mine and that the Deepin installer does start properly on it.

I am running out of ideas to fix this issue, any suggestion?

protected by Community Aug 13 at 19:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.