1

I'm using Debian testing with Gnome. For some reason it takes around a three minutes to login, after I have typed in the password and pressed enter. What could the reason be? I would love to provide more details, but I have no idea about where to even start.

On demand:

$ cat /etc/hosts
127.0.0.1   localhost
127.0.1.1   klutt-desktop.klutt klutt-desktop

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

On demand 2:

$ systemd-analyze blame | head -n3
    1min 25.769s ssh.service
          6.764s NetworkManager-wait-online.service
           612ms udisks2.service

Seems to be ssh. Checking journaltcl

$ sudo journalctl | grep ssh
Dec 17 10:09:53 klutt-desktop systemd[828]: Listening on GnuPG cryptographic agent (ssh-agent emulation).
Dec 17 10:10:03 klutt-desktop systemd[1126]: Listening on GnuPG cryptographic agent (ssh-agent emulation).
Dec 17 10:11:22 klutt-desktop systemd[1]: ssh.service: Start-pre operation timed out. Terminating.
Dec 17 10:11:22 klutt-desktop systemd[1]: ssh.service: Failed with result 'timeout'.
Dec 17 10:11:22 klutt-desktop systemd[1]: ssh.service: Service RestartSec=100ms expired, scheduling restart.
Dec 17 10:11:22 klutt-desktop systemd[1]: ssh.service: Scheduled restart job, restart counter is at 1.
Dec 17 10:12:48 klutt-desktop sshd[1151]: Server listening on 0.0.0.0 port 22.
Dec 17 10:12:48 klutt-desktop sshd[1151]: Server listening on :: port 22.
Dec 17 10:12:50 klutt-desktop gnome-keyring-ssh.desktop[1232]: SSH_AUTH_SOCK=/run/user/1000/keyring/ssh

A piece from journalctl from a later reboot, after I ran systemctl disable ssh.service:

Dec 17 11:12:37 klutt-desktop systemd[1]: Startup finished in 3.587s (kernel) + 13.916s (userspace) = 17.504s.
Dec 17 11:12:56 klutt-desktop systemd-timesyncd[696]: Synchronized to time server 79.136.86.176:123 (2.debian.pool.
Dec 17 11:12:57 klutt-desktop dbus-daemon[740]: [system] Failed to activate service 'org.bluez': timed out (service
Dec 17 11:12:57 klutt-desktop pulseaudio[874]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freed
Dec 17 11:13:33 klutt-desktop geoclue[923]: Service not used for 60 seconds. Shutting down..
Dec 17 11:13:34 klutt-desktop realmd[1043]: quitting realmd service after timeout
Dec 17 11:13:34 klutt-desktop realmd[1043]: stopping service
Dec 17 11:15:17 klutt-desktop kernel: random: crng init done

geoclue and realmd seems to be candidates.

  • 1
    "Around a minute"? 30 seconds is the default timeout for a failed DNS lookup. Perhaps you're missing an 127.0.0.1 and ::1 stanza in /etc/hosts or similar... – Shadur Dec 17 '18 at 9:15
  • 1
    @jimmij Here is the output. I did not know what to look for: pastebin.com/NKxvpLqx – Broman Dec 17 '18 at 9:15
  • 1
    @GAD3R No failed services. – Broman Dec 17 '18 at 9:16
  • 1
    I'm seeing a couple things timing out near line 1816, and the timestamp moves from 10:09 to 10:12 pretty quickly around that point. – Shadur Dec 17 '18 at 9:29
  • 2
    Check the output of systemd-analyze blame . – jimmij Dec 17 '18 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.