0

I am trying to install this plugin here for my Vim on my Centos 7 laptop. The instructions I followed to install the plugin manage Vundle are from the Github Vundle page here and then proceeded to follow instructions for the plugin installation in it's github page as well.

This is what my .vimrc file currently looks like which is practically taken from the Github Vundle page.

set nocompatible              " be iMproved, required
filetype off                  " required

" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" " alternatively, pass a path where Vundle should install plugins
" "call vundle#begin('~/some/path/here')
"
" " let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'
"
" " The following are examples of different formats supported.
" " Keep Plugin commands between vundle#begin/end.
" " plugin on GitHub repo
Plugin 'tpope/vim-fugitive'
" " plugin from http://vim-scripts.org/vim/scripts.html
" " Plugin 'L9'
" " Git plugin not hosted on GitHub
Plugin 'git://git.wincent.com/command-t.git'
" " git repos on your local machine (i.e. when working on your own plugin)
"Plugin 'file:///home/gmarik/path/to/plugin'
" " The sparkup vim script is in a subdirectory of this repo called vim.
" " Pass the path to set the runtimepath properly.
Plugin 'rstacruz/sparkup', {'rtp': 'vim/'}
" " Install L9 and avoid a Naming conflict if you've already installed a
" " different version somewhere else.
" " Plugin 'ascenator/L9', {'name': 'newL9'}
"
" " All of your Plugins must be added before the following line

"Adam - my plugins
Plugin 'itchyny/lightline.vim' "download from - https://github.com/itchyny/lightline.vim
call vundle#end()            " required
filetype plugin indent on    " required
" " To ignore plugin indent changes, instead use:
" "filetype plugin on
" "
" " Brief help
" " :PluginList       - lists configured plugins
" " :PluginInstall    - installs plugins; append `!` to update or just
" :PluginUpdate
" " :PluginSearch foo - searches for foo; append `!` to refresh local cache
" " :PluginClean      - confirms removal of unused plugins; append `!` to
" auto-approve removal
" "
" " see :h vundle for more details or wiki for FAQ
" " Put your non-Plugin stuff after this line
"-----------------------------------------------------------------------------------------

"show numbers on lines
"set number
".vimrc" 54L, 2126C                                                                                                                 52,1          90%

I save and close the file. Open vim again and run :PluginInstall and it seems to be installing as I get the result below shown in this

image

I then close vim and terminal, reopen everything but my status line still looks like this.

  • Looks like you missed setting laststatus. – muru Dec 17 '18 at 3:19
2

New answer:

Maybe it is a configuration problem of the plugin, try adding set laststatus=2 to your .vimrc - for details see: https://github.com/itchyny/lightline.vim#introduction

Old answer:

it seems that you are missing call vundle#begin():

Check example in the https://github.com/VundleVim/Vundle.vim#quick-start

Keep Plugin commands between vundle#begin/end.

  • i apologize, i did not notice i only pasted a section of my .vimrc file, I updated the code to show the entire file and it is in there. – AMVPlusPlus Dec 17 '18 at 1:51
  • The issue is with the status bar not looking as per plugin? It seems all is working but needs a bit of configuration - answer updated. – Evolter Dec 17 '18 at 3:15
  • Solved. I was under the assumption that I did not need to put this in the line "set laststatus = 2" since my status line was not entirely blank like the document shows so did not bother to try it but it was the solution to my problem. Thank you. – AMVPlusPlus Dec 27 '18 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.