0

So this issue is actually occurring between OSX and CentOS. I created an ssh mount using osxfuse:

sshfs [ssh config name]:/remote/location/dir.ec.tory ~/client/location/dir.ec.tory -o follow_symlinks

This had worked, but I imagine there was a timeout of some nature (or the server stopped responding) and the linkage broke. When attempting to unmount (via umount) there were issues:

umount: ~/client/location/dir.ec.tory: not currently mounted

That's not uncommon; however ls -la no longer shows the directory. Even if the there is no connection, the directories would remain after and be mounted on the local file system. I have other directories that point to different paths on the server — these all worked and nothing has changed.

When trying to remount this is the error displayed:

sshfs [ssh config name]:/remote/location/dir.ec.tory ~/client/location/dir.ec.tory -o follow_symlinks
mount_osxfuse: /Users/<name>/SSH/dir.ec.tory: Input/output error

It's odd that ls does not show the directory. Even odder is that tab-completion still worked for the directory. Even trying to remove the directory sudo rm ~/client/location/dir.ec.tory it receives the same Input/output error. If I try to remake the directory (mkdir ~/client/location/dir.ec.tory) it says File exists

Does anyone know why or how I could display the directory again and recover from this error? I've killed all the processes I could find related to ssh asside from the daemon.

0

Turns out not all processes were terminated. There seemed to be a rogue process not assigned to my account. Revealed by:

ps -ax | grep ssh

Killing the id that belonged to that process must have released something as the directory once again appeared and was re-accessible. I'm not familiar with the terminal/fs enough to know why ls would not discover that directory, but would appreciate any insights some more experienced could divulge.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.